View Issue Details

IDProjectCategoryView StatusLast Update
0019270mantisbtdocumentationpublic2016-08-15 09:02
ReporteratrolAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.19 
Target Version1.2.20Fixed in Version1.2.20 
Summary0019270: Missing documentation from 1.2.19 download
Description

Official download of 1.2.19 [1] does no longer contain directory doc/en with administrators and developers guide.

[1] https://sourceforge.net/projects/mantisbt/files/mantis-stable/1.2.19/

TagsNo tags attached.

Activities

dregad

dregad

2015-01-27 02:47

developer   ~0048698

Something must have gone wrong in the packaging script. Will check.

dregad

dregad

2015-01-27 03:41

developer   ~0048699

I must have forgotten to specify the '-d' flag to generate packages.

Anyway I reran the script and confirmed the documentation is included. Waiting for vboctor to upload to Sourceforge.

atrol

atrol

2015-01-27 04:21

developer   ~0048700

Not sure if it's a good idea to have two different versions of 1.2.19.
We had already about 660 downloads.

dregad

dregad

2015-01-27 04:42

developer   ~0048701

It's not a "different" version, it's the same plus the docs -- that nobody reads anyway ;-)

atrol

atrol

2015-01-27 04:56

developer   ~0048702

My concern is that there are two versions of mantisbt-1.2.19.zip with different MD5/SHA1 sums.

Ok, nobody checks the sums ;-)

dregad

dregad

2015-01-27 08:26

developer   ~0048706

Sorry, just realized I resolved this by mistake.

vboctor

vboctor

2015-01-27 18:28

manager   ~0048708

Last edited: 2015-01-27 18:29

View 2 revisions

I would just skip this for 1.2.19, just let's make sure it happens by default for future versions of 1.2. and 1.3.. The docs are the same as 1.2.18 and if user overwrites (as they would typically do for minor version upgrades), then they will have the docs.

I understand that new users won't have it, but it is on our website.

dregad

dregad

2015-01-28 04:13

developer   ~0048719

I would just skip this for 1.2.19
I understand that new users won't have it, but it is on our website.

In that case, maybe a README file (and a blog post ?) pointing users to download the docs from http://mantisbt.org/documentation.php would be useful.

just let's make sure it happens by default for future versions of 1.2. and 1.3..

You mean changing the release build script ?

dregad

dregad

2015-02-13 17:21

developer   ~0048820

Resolving as won't fix based on vboctor's comment.

atrol

atrol

2015-02-14 05:06

developer   ~0048823

won't fix?
I assume it will be fixed in 1.2.20.
Am I wrong?

dregad

dregad

2015-02-16 03:09

developer   ~0048830

I assume it will be fixed in 1.2.20.

Correct.

atrol

atrol

2015-09-08 15:50

developer   ~0051404

Reminder sent to: dregad

Why did you close?
Does this mean that there will be no version 1.2.20?

dregad

dregad

2015-09-09 03:09

developer   ~0051415

I closed it because the doc was missing due to a human error (I forgot to specify a flag when packaging the archives), not a bug in the release script. Since Victor said he would not fix the 1.2.19, I didn't see the point in keeping this opened (it was in resolved status since February)

This is independent from 1.2.20 release.

atrol

atrol

2015-09-09 03:23

developer   ~0051416

As an end user I read at the moment:
There is no documentation in 1.2.19, status is "closed", resolution is "won't fix", thus there will also be no documentation in 1.2.20.

I prefer to resolve this issue at the moment, set "Fixed in Version" and close the issue after there is a version 1.2.20.
End users will see in roadmap and change log, that next version will include the documentation again.

dregad

dregad

2015-09-09 03:58

developer   ~0051417

As you wish.

Issue History

Date Modified Username Field Change
2015-01-26 14:33 atrol New Issue
2015-01-27 02:47 dregad Assigned To => dregad
2015-01-27 02:47 dregad Status new => assigned
2015-01-27 02:47 dregad Note Added: 0048698
2015-01-27 03:33 atrol Summary Mssing documentation => Missing documentation
2015-01-27 03:41 dregad Note Added: 0048699
2015-01-27 04:21 atrol Note Added: 0048700
2015-01-27 04:42 dregad Note Added: 0048701
2015-01-27 04:52 dregad Status assigned => resolved
2015-01-27 04:52 dregad Fixed in Version => 1.3.0-beta.2
2015-01-27 04:52 dregad Resolution open => fixed
2015-01-27 04:56 atrol Note Added: 0048702
2015-01-27 08:26 dregad Status resolved => assigned
2015-01-27 08:26 dregad Resolution fixed => reopened
2015-01-27 08:26 dregad Fixed in Version 1.3.0-beta.2 =>
2015-01-27 08:26 dregad Target Version 1.2.20 =>
2015-01-27 08:26 dregad Note Added: 0048706
2015-01-27 18:28 vboctor Note Added: 0048708
2015-01-27 18:29 vboctor Note Edited: 0048708 View Revisions
2015-01-27 18:29 vboctor Summary Missing documentation => Missing documentation from 1.2.19 download
2015-01-28 04:13 dregad Note Added: 0048719
2015-02-01 09:43 atrol Target Version => 1.2.20
2015-02-13 17:21 dregad Assigned To dregad => vboctor
2015-02-13 17:21 dregad Status assigned => resolved
2015-02-13 17:21 dregad Resolution reopened => won't fix
2015-02-13 17:21 dregad Note Added: 0048820
2015-02-14 05:06 atrol Note Added: 0048823
2015-02-16 03:09 dregad Note Added: 0048830
2015-03-02 08:04 vitsaadmin Issue cloned: 0019447
2015-09-07 03:35 dregad Target Version 1.2.20 =>
2015-09-07 03:39 dregad Status resolved => closed
2015-09-08 15:50 atrol Note Added: 0051404
2015-09-09 03:09 dregad Note Added: 0051415
2015-09-09 03:23 atrol Note Added: 0051416
2015-09-09 03:58 dregad Note Added: 0051417
2015-09-09 04:27 atrol Status closed => resolved
2015-09-09 04:27 atrol Resolution won't fix => fixed
2015-09-09 04:27 atrol Fixed in Version => 1.2.20
2015-09-09 04:27 atrol Target Version => 1.2.20
2016-08-15 09:02 dregad Status resolved => closed