View Issue Details

IDProjectCategoryView StatusLast Update
0018049mantisbtapi soappublic2016-08-15 09:02
ReporteratrolAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.16 
Target Version1.2.20Fixed in Version1.2.20 
Summary0018049: Getting errors when accessing SOAP documentation page
Description

Accessing page api/soap/mantisconnect.php?wsdl tries to fetch the non existing file wsdl-viewer.js

You get entries like the following one in Apache error log
File does not exist: <yourPath>/api/soap/wsdl-viewer.js

This is caused by the implementation of 0015959

TagsNo tags attached.

Relationships

related to 0015959 closeddregad SOAP: raw XML when browsing the WSDL 

Activities

dregad

dregad

2015-01-22 04:04

developer   ~0042241

I have no idea what the purpose of this file is. I tried:

  • removing the <script> block from the XSL
  • adding a dummy wsdl-viewer.js file
  • downloading what seems to be the original javascript from [1]

In all 3 cases, the error message disappears from the error logs, but I don't notice any difference when browsing the WSDL.

I just sent a mail to the wsdl-viewer.xsl author, hopefully he can provide some insight.

[1] https://svn.apache.org/repos/asf/webservices/woden/branches/woden-20/wsdl-viewer/src/

dregad

dregad

2015-02-02 05:03

developer   ~0048765

After discussion with Tomi Vanek (author of the XSLT), it turns out that the javascript does not server any purpose, and can be removed.

On 23 January 2015 at 18:03, Tomi Vanek <tomi.vanek@gmail.com> wrote:

JS - that was just a plan that was never finished - browsers block JS from file
system, so I did not go in that direction, just forgot the link in generated
code - this is a harmless bug

Related Changesets

MantisBT: master-1.2.x 21832b8b

2015-02-02 04:48:29

dregad

Details Diff
SOAP: remove useless script block from XSLT

The js file referenced in the XSLT is missing from the distribution,
which causes errors in the apache error logs:
File does not exist: /path/to/mantisbt/api/soap/wsdl-viewer.js

As per the XSLT's author,

On 23 January 2015 at 18:03, Tomi Vanek <tomi.vanek@gmail.com> wrote:
> JS - that was just a plan that was never finished - browsers block JS
> from file system, so I did not go in that direction, just forgot the
> link in generated code - this is a harmless bug

This commit resolves the issue by removing the <script> block from the
XSLT file.

Fixes 0018049
mod - api/soap/wsdl-viewer.xsl Diff File

MantisBT: master 6c31ff9c

2015-02-02 04:48:29

dregad

Details Diff
SOAP: remove useless script block from XSLT

The js file referenced in the XSLT is missing from the distribution,
which causes errors in the apache error logs:
File does not exist: /path/to/mantisbt/api/soap/wsdl-viewer.js

As per the XSLT's author,

On 23 January 2015 at 18:03, Tomi Vanek <tomi.vanek@gmail.com> wrote:
> JS - that was just a plan that was never finished - browsers block JS
> from file system, so I did not go in that direction, just forgot the
> link in generated code - this is a harmless bug

This commit resolves the issue by removing the <script> block from the
XSLT file.

Fixes 0018049
mod - api/soap/wsdl-viewer.xsl Diff File

Issue History

Date Modified Username Field Change
2015-01-21 15:39 atrol New Issue
2015-01-21 15:40 atrol Relationship added related to 0015959
2015-01-22 04:04 dregad Status new => confirmed
2015-01-22 04:04 dregad Note Added: 0042241
2015-02-02 05:00 dregad Changeset attached => MantisBT master-1.2.x 21832b8b
2015-02-02 05:00 dregad Assigned To => dregad
2015-02-02 05:00 dregad Status confirmed => resolved
2015-02-02 05:00 dregad Resolution open => fixed
2015-02-02 05:00 dregad Fixed in Version => 1.2.20
2015-02-02 05:01 dregad Changeset attached => MantisBT master 6c31ff9c
2015-02-02 05:03 dregad Target Version => 1.2.20
2015-02-02 05:03 dregad Note Added: 0048765
2016-08-15 09:02 dregad Status resolved => closed