View Issue Details

IDProjectCategoryView StatusLast Update
0018034mantisbttimelinepublic2015-03-15 19:58
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0018034: Number of events in timeline is sometimes less than 50
Description

Even when there are more than 50 events to display, the timeline sometimes display less entries than that.

TagsNo tags attached.

Relationships

related to 0018035 closeddregad Timeline "More events" link should only appear when necessary 

Activities

dregad

dregad

2015-01-19 18:54

developer   ~0042209

Pull request for review https://github.com/mantisbt/mantisbt/pull/567

Related Changesets

MantisBT: master 523bf91d

2015-01-19 13:37:48

dregad

Details Diff
Fix number of displayed events lower than 50

Depending on the types of events displayed, in some cases the timeline
displayed fewer than 50 entries even though more are available.

This is because the 'Status Change' timeline events are only printed for
some status types (RESOLVED, CLOSED, REOPENED); prior to this, other
types were printed as an empty string.

This adds a new private method in IssueStatusChangeTimelineEvent class
to determine the type of status change in the constructor and store it
as a property, which is then used to reimplement the skip() method as
well as to drive html generation. This allows the timeline_events()
function to exclude unwanted entries with skip().

In addition, the logic for limiting the number of items to display is
now implemented in timeline_print_events() instead of timeline_inc.php.

Fixes 0018034
mod - core/classes/IssueStatusChangeTimelineEvent.class.php Diff File
mod - core/classes/TimelineEvent.class.php Diff File
mod - core/timeline_api.php Diff File
mod - core/timeline_inc.php Diff File

Issue History

Date Modified Username Field Change
2015-01-19 17:27 dregad New Issue
2015-01-19 17:27 dregad Status new => assigned
2015-01-19 17:27 dregad Assigned To => dregad
2015-01-19 18:51 dregad Relationship added related to 0018035
2015-01-19 18:54 dregad Note Added: 0042209
2015-01-22 09:14 dregad Changeset attached => MantisBT master 523bf91d
2015-01-22 09:14 dregad Status assigned => resolved
2015-01-22 09:14 dregad Resolution open => fixed
2015-01-22 09:14 dregad Fixed in Version => 1.3.0-beta.2
2015-01-27 19:20 atrol Category bugtracker => timeline
2015-03-15 19:58 dregad Status resolved => closed