View Issue Details

IDProjectCategoryView StatusLast Update
0018015mantisbttimelinepublic2015-09-06 17:37
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.0-beta.1 
Target Version1.3.0-beta.3Fixed in Version1.3.0-beta.3 
Summary0018015: Refactor history_api to build timeline more efficiently
Description

The timeline code currently works as follows:

  • Figure out issues modified based on a time window based on history table.
  • For each issue, retrieve history events to re-use code for processing such entries and do the authz.
  • Merge the entries and sort them.
  • Pick the top 50.

Ideally the algorithm should change to be based on iterating through entries in history table within time range from newest to oldest and do the following for each ones:

  • Do the authz and processing of the raw.
  • Add raw to list to be displayed to user.
  • If list is 50 stop.

With this approach we only process the N we are displaying to the user, while re-using the refactored code from the history api.

Tagsmantishub

Relationships

related to 0017966 closedvboctor My View Page takes about 5s to load 
related to 0019945 closedvboctor Timeline should take selected project into consideration 

Activities

vboctor

vboctor

2015-07-06 02:30

manager   ~0051015

Pull Request:
https://github.com/mantisbt/mantisbt/pull/614

Related Changesets

MantisBT: master bb100e68

2015-07-14 01:06:35

vboctoradmin

Details Diff
Merge pull request 0000614 from vboctor/Issue18015_timeline_speed

Fixes 0018015: Refactor history_api to build timeline more efficiently
mod - core/classes/IssueAssignedTimelineEvent.class.php Diff File
mod - core/classes/IssueCreatedTimelineEvent.class.php Diff File
mod - core/classes/IssueMonitorTimelineEvent.class.php Diff File
mod - core/classes/IssueNoteCreatedTimelineEvent.class.php Diff File
mod - core/classes/IssueStatusChangeTimelineEvent.class.php Diff File
mod - core/classes/IssueTagTimelineEvent.class.php Diff File
mod - core/classes/TimelineEvent.class.php Diff File
mod - core/history_api.php Diff File
mod - core/timeline_api.php Diff File
mod - core/timeline_inc.php Diff File

MantisBT: master adbd0882

2015-07-20 09:22:32

vboctor

Details Diff
Timeline should honor current project

Fixes 0019945

This fix a regression caused by issue 0018015
mod - core/history_api.php Diff File

MantisBT: master e475711a

2015-07-22 05:46:17

vboctor

Details Diff
Fix access check for timeline events

Issue 0018015
mod - core/history_api.php Diff File

MantisBT: master dc11fa94

2015-07-22 06:17:01

vboctor

Details Diff
Cache access check for timeline issues

Issue 0018015
mod - core/history_api.php Diff File

Issue History

Date Modified Username Field Change
2015-01-14 04:05 vboctor New Issue
2015-01-14 04:05 vboctor Relationship added related to 0017966
2015-01-27 19:19 atrol Category time tracking => timeline
2015-05-29 12:14 vboctor Tag Attached: mantishub
2015-05-29 12:14 vboctor Assigned To => vboctor
2015-05-29 12:14 vboctor Status new => assigned
2015-07-06 02:30 vboctor Note Added: 0051015
2015-07-14 01:06 vboctoradmin Changeset attached => MantisBT master bb100e68
2015-07-14 01:06 vboctoradmin Assigned To vboctor => vboctoradmin
2015-07-14 01:06 vboctoradmin Status assigned => resolved
2015-07-14 01:06 vboctoradmin Resolution open => fixed
2015-07-14 01:06 vboctoradmin Fixed in Version => 1.3.0-beta.3
2015-07-14 01:08 vboctor Assigned To vboctoradmin => vboctor
2015-07-14 01:51 atrol Target Version => 1.3.0-beta.3
2015-07-20 09:19 vboctor Relationship added related to 0019945
2015-07-20 09:22 vboctor Changeset attached => MantisBT master adbd0882
2015-07-22 05:46 vboctor Changeset attached => MantisBT master e475711a
2015-07-22 06:17 vboctor Changeset attached => MantisBT master dc11fa94
2015-09-06 17:37 vboctoradmin Status resolved => closed