View Issue Details

IDProjectCategoryView StatusLast Update
0017971mantisbtuipublic2015-01-15 16:18
ReporterKristianAssigned Todregad 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.18 
Target VersionFixed in Version1.3.0-beta.1 
Summary0017971: anchor tags don't closed
Description

At some pages the anchor tags aren't closed properly (for example the project edit page - manage_proj_edit_page.php). The tags are closed with "/" but the browsers don't recognize it (see attached screenshot, tested with firefox 34). Because of that, the whole section which follows the anchor is marked as a link. And if I move the mouse into this section the whole section will get underlined because this is my mouse over style for a:link.

TagsNo tags attached.

Activities

Kristian

Kristian

2014-12-17 12:24

reporter  

manits_not_closing_a.jpg (82,835 bytes)
manits_not_closing_a.jpg (82,835 bytes)
dregad

dregad

2014-12-22 04:31

developer   ~0042046

Thanks for the bug report.

We've implemented many changes and improvements to the generated HTML in upcoming MantisBT version 1.3 - would you be able to test if the problem is still present in the current beta release (download from [1]) ?

Thanks in advance.

[1] http://mantisbt.org/download.php

Kristian

Kristian

2014-12-29 06:42

reporter   ~0042068

Thank you for your reply. It seems, that the anchor tags are removed in version 1.3. Because of that the problem don't exists anymore in 1.3.

dregad

dregad

2014-12-29 18:06

developer   ~0042072

Thanks for your feedback. I'll mark this as resolved in version 1.3.

Since this is a minor issue, I don't think it's worth the effort to backport the fix to 1.2.

Issue History

Date Modified Username Field Change
2014-12-17 12:24 Kristian New Issue
2014-12-17 12:24 Kristian File Added: manits_not_closing_a.jpg
2014-12-22 04:31 dregad Status new => feedback
2014-12-22 04:31 dregad Note Added: 0042046
2014-12-29 06:42 Kristian Note Added: 0042068
2014-12-29 06:42 Kristian Status feedback => new
2014-12-29 18:06 dregad Assigned To => dregad
2014-12-29 18:06 dregad Status new => resolved
2014-12-29 18:06 dregad Resolution open => fixed
2014-12-29 18:06 dregad Fixed in Version => 1.3.0-beta.1
2014-12-29 18:06 dregad Note Added: 0042072
2015-01-15 16:18 atrol Status resolved => closed