View Issue Details

IDProjectCategoryView StatusLast Update
0017919mantisbtuipublic2016-07-19 04:19
ReportervboctorAssigned Tosyncguru 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.2.17 
Target Version2.0.0-beta.1Fixed in Version2.0.0-beta.1 
Summary0017919: Modernize Mantis UI
Description

Implement a modern UI using bootstrap and jQuery.

Tagsmantishub

Relationships

related to 0019590 closedsyncguru Attach via drag-and-drop 
has duplicate 0010409 closedvboctor New graphic design draft 
has duplicate 0016242 closedvboctor Responsive design 
related to 0012339 new Design proposal for "View bug" to increase readability and reduce clutter 
related to 0006628 closedvboctor Skinning 
related to 0004227 acknowledged Roadmap 1.0 - Templates 
related to 0017711 closed Move menu generation functionality into Menu Class and update CSS 
related to 0012203 confirmed Request that Bug Note + History be merged in chronological order 
related to 0020102 closedsyncguru Support switching saved filters and free text search when filter box is collapsed 
related to 0020118 closedsyncguru pen icon ancient 

Activities

vboctor

vboctor

2014-11-25 11:33

manager   ~0041909

Pull request with screenshots:
https://github.com/mantisbt/mantisbt/pull/272

vboctor

vboctor

2015-01-31 21:51

manager   ~0048758

Here is a link to Bugzilla's modern UI
https://bugzillaupdate.files.wordpress.com/2011/03/jwilde-bugzillapretty-bug-27-2-2011.png

aavagyan

aavagyan

2015-07-01 15:26

reporter   ~0051001

Dear Victor,

Is there a timeline for this modern UI implementation? I'm using it in my local dev. environment and find it really good.

aavagyan

aavagyan

2015-07-02 08:51

reporter   ~0051006

I have couple of suggestions (and will have more) - is there place to submit these?

dregad

dregad

2015-07-02 11:59

developer   ~0051007

For the time being, unless Victor has a better idea, I would suggest to open new issues here, with product version "2.0.x", category "ui" and mentioning that this is an improvement or bug related to the modern UI (referencing this issue).

aavagyan

aavagyan

2015-07-02 16:39

reporter   ~0051008

Thanks, will do so. May you please add '2.0.x' to the product versions?

codvir

codvir

2015-07-03 07:51

reporter   ~0051009

Looking forward to a new modern UI.
I think that it is a must.
Sometimes I feel that the current UI is a time machine which takes me to the 80's.

Just joking ;) I really like Mantisbt over others, and looking forward to a new UI design.

dregad

dregad

2015-07-03 08:24

developer   ~0051010

May you please add '2.0.x' to the product versions?

Actually the version already exists but is only visible to developers since it's not released yet. I invite you to open issues anyway and I'll update them.

aavagyan

aavagyan

2015-07-22 04:00

reporter   ~0051107

Dears,

I'm now using code from https://github.com/mantisbt/mantisbt/pull/272. It this what you want me to report on or there is another version/code somewhere else?

I really need to know your tentative timeline on getting this UI on top of your production version. May you please share your ideas on this point?

Thanks!

badfiles

badfiles

2015-07-22 05:03

reporter   ~0051108

You can try this.
It has some problems, but I think it works.

https://github.com/badfiles/mantisbt/tree/master-modern-ui

aavagyan

aavagyan

2015-07-27 06:48

reporter   ~0051139

@badfiles What is the difference between https://github.com/badfiles/mantisbt/tree/master-modern-ui and https://github.com/mantisbt/mantisbt/pull/272?

https://github.com/mantisbt/mantisbt/pull/272 works for me.

Dear Victor and Damian, may you please respond to this question?

I really need to know your tentative timeline on getting this UI on top of your production version. May you please share your ideas on this point?

Thank you

badfiles

badfiles

2015-07-27 07:08

reporter   ~0051140

What is the difference between
It includes latest original git commits.

syncguru

syncguru

2015-08-16 00:01

developer   ~0051267

New update to the Modern UI pull request. https://github.com/mantisbt/mantisbt/pull/272

It is now more current with master plus support for drag and drop. (see animated gif for demo)



dragNdrop.gif (562,638 bytes)

Issue History

Date Modified Username Field Change
2014-11-25 11:33 vboctor New Issue
2014-11-25 11:33 vboctor Status new => assigned
2014-11-25 11:33 vboctor Assigned To => syncguru
2014-11-25 11:33 vboctor Note Added: 0041909
2014-11-25 11:34 vboctor Relationship added has duplicate 0010409
2014-11-25 11:35 vboctor Relationship added related to 0012339
2014-11-25 11:36 vboctor Relationship added related to 0006628
2014-11-25 11:37 vboctor Relationship added related to 0004227
2014-11-25 12:22 vboctor Relationship added related to 0017711
2015-01-31 21:51 vboctor Note Added: 0048758
2015-01-31 21:53 vboctor Relationship added related to 0012203
2015-02-14 13:35 vboctor Relationship added has duplicate 0016242
2015-03-02 08:04 vitsaadmin Issue cloned: 0019451
2015-04-08 12:07 vboctor Relationship added related to 0019590
2015-04-29 06:33 atrol Target Version => 2.0.0-beta.1
2015-04-29 11:00 vboctor Tag Attached: mantishub
2015-07-01 15:26 aavagyan Note Added: 0051001
2015-07-01 15:47 kauepaulo Issue cloned: 0019897
2015-07-02 08:51 aavagyan Note Added: 0051006
2015-07-02 11:59 dregad Note Added: 0051007
2015-07-02 16:39 aavagyan Note Added: 0051008
2015-07-03 07:51 codvir Note Added: 0051009
2015-07-03 08:24 dregad Note Added: 0051010
2015-07-22 04:00 aavagyan Note Added: 0051107
2015-07-22 05:03 badfiles Note Added: 0051108
2015-07-27 06:48 aavagyan Note Added: 0051139
2015-07-27 07:08 badfiles Note Added: 0051140
2015-08-16 00:01 syncguru File Added: dragNdrop.gif
2015-08-16 00:01 syncguru Note Added: 0051267
2015-09-11 09:22 atrol Relationship added related to 0020102
2015-09-15 15:49 atrol Relationship added related to 0020118
2016-07-10 03:26 atrol Status assigned => resolved
2016-07-10 03:26 atrol Resolution open => fixed
2016-07-10 03:26 atrol Fixed in Version => 2.0.0-beta.1
2016-07-19 04:19 vboctor Status resolved => closed