View Issue Details

IDProjectCategoryView StatusLast Update
0017520mantisbtfilterspublic2014-12-08 00:34
ReporternoizegAssigned Todregad 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.17 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0017520: "Project not found" error after deleting project
Description

If user has used "project" filter value in cashed filters, he will get "project not found" error if one of filtered projects was deleted.
User won't be able to clear his cashed filter by himself, and won't be able to view project anymore.

Admin must remove filter records in DB for this user to fix it.

Steps To Reproduce
  1. (ADMIN) Create two projects. "Project 1", "project 2".
  2. (USER) Switch to All Projects page.
  3. (USER) Go to advanced filters and click on "Project" filter option.
  4. (USER) Select "current", "Project 1", "Project 2" in list. Apply filter.
  5. (USER) Switch to "Project 2" page.
  6. (USER) Click on "Project" filter option again.
  7. (USER) Select "Project 1", "Project 2" in list. Apply filter.
  8. (ADMIN) Delete "Project 1".
  9. (USER) Switch to All Projects page.
    10.(USER) Switch back to "Project 2" page.
    11.(USER) Should get APPLICATION ERROR 0000700. Project not found.
Additional Information

I can't fix it in code by myself, because can't understand at which moment trigger_error() is called.

TagsNo tags attached.

Activities

noizeg

noizeg

2014-07-17 03:20

reporter  

2014-07-17_104802.png (7,429 bytes)
2014-07-17_104802.png (7,429 bytes)
noizeg

noizeg

2014-07-17 03:20

reporter  

2014-07-17_105123.png (13,977 bytes)
2014-07-17_105123.png (13,977 bytes)
noizeg

noizeg

2014-07-17 03:21

reporter   ~0040932

One more thing, you can see on screenshot that "All Projects" page is working, and filter has empty value.

Related Changesets

MantisBT: master 15c75c64

2014-07-24 19:37:46

dregad

Details Diff
Check project existence before access level

Failure to do so causes "Project not found" error when a user has a
cached filter on a project that has been deleted.

Fixes 0017520
mod - core/filter_api.php Diff File

Issue History

Date Modified Username Field Change
2014-07-17 03:20 noizeg New Issue
2014-07-17 03:20 noizeg File Added: 2014-07-17_104802.png
2014-07-17 03:20 noizeg File Added: 2014-07-17_105123.png
2014-07-17 03:21 noizeg Note Added: 0040932
2014-08-07 17:59 dregad Changeset attached => MantisBT master 15c75c64
2014-08-07 17:59 dregad Assigned To => dregad
2014-08-07 17:59 dregad Status new => resolved
2014-08-07 17:59 dregad Resolution open => fixed
2014-08-07 17:59 dregad Fixed in Version => 1.3.0-beta.1
2014-08-07 18:01 dregad Target Version => 1.3.0-beta.1
2014-12-08 00:34 vboctor Status resolved => closed