View Issue Details

IDProjectCategoryView StatusLast Update
0017359mantisbtplug-inspublic2014-12-08 00:34
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.17 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0017359: Errors when loading a plugin's page when its dependencies are not met
Description

plugin.php checks that a plugin is registered, but not that it's successfully loaded.

Consequently the page loads but is likely to trigger errors.

Steps To Reproduce
TagsNo tags attached.

Activities

grangeway

grangeway

2014-06-01 17:27

reporter   ~0040705

Is the purpose of https://github.com/mantisbt/mantisbt/pull/179 to fix this?

Related Changesets

MantisBT: master 61118a18

2014-05-20 03:48:50

dregad

Details Diff
Check that a plugin is loaded when accessing its pages

A plugin can be registered yet fail to load for example due to unmet
dependencies.

Fixes 0017359
mod - core/constant_inc.php Diff File
mod - lang/strings_english.txt Diff File
mod - plugin.php Diff File

MantisBT: master 506088e1

2014-06-02 04:41:05

Damien Regad

Details Diff
Various plugin-related fixes and enhancements

- Check that a plugin is loaded when accessing its pages to prevent
errors
- Improved error messages
- Simplified handling of MantisCore pseudo-plugin
- Remove direct access to $g_plugin_cache global variable
- Improved plugin file validation regex
- No re-registration of previously registered plugins
- Fixed data type issues in plugin API
- Various code cleanup and whitespace fixes

Fixes 0017359, 0017366, 0017368
mod - core/constant_inc.php Diff File
mod - core/plugin_api.php Diff File
mod - core/print_api.php Diff File
mod - lang/strings_english.txt Diff File
mod - manage_plugin_page.php Diff File
mod - plugin.php Diff File
mod - plugin_file.php Diff File

Issue History

Date Modified Username Field Change
2014-05-20 04:06 dregad New Issue
2014-05-20 04:06 dregad Status new => assigned
2014-05-20 04:06 dregad Assigned To => dregad
2014-06-01 17:27 grangeway Note Added: 0040705
2014-06-02 05:01 dregad Changeset attached => MantisBT master 506088e1
2014-06-02 05:02 dregad Changeset attached => MantisBT master 61118a18
2014-06-02 05:02 dregad Status assigned => resolved
2014-06-02 05:02 dregad Fixed in Version => 1.3.0-beta.1
2014-06-02 05:02 dregad Resolution open => fixed
2014-12-08 00:34 vboctor Status resolved => closed