View Issue Details

IDProjectCategoryView StatusLast Update
0017279mantisbtemailpublic2015-09-06 17:37
ReportergrangewayAssigned Todregad 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.3Fixed in Version1.3.0-beta.3 
Summary0017279: Email addresses validation and parsing is not consistent
Description

Currently, Mantis uses two different calculations for detecting email addresses within a text string, and for validating email addresses.

To ensure the same behaviour for users, the same detection logic should be used for calculating email addresses in both cases.

TagsNo tags attached.

Relationships

related to 0017275 closeddregad email matching within Mantis should follow html5 standard 
related to 0016894 closeddregad Don't allow invalid email addresses (e.g. fred@localhost) to be used when signing up 

Activities

dregad

dregad

2015-04-16 18:28

developer   ~0049426

We should use HTML5 standard for both processes, as discussed in PR 172

Related Changesets

MantisBT: master 3b584404

2014-06-03 11:54:48

dregad

Details Diff
Add HTML5 email validation method (as default)

As per grangeway's suggestion in pull request 172, we are now using an
HTML5 specification-compliant regex to validate e-mail addresses by
default instead of PHP method.

Issue 0017275, 0017279
mod - config_defaults_inc.php Diff File
mod - core/constant_inc.php Diff File
mod - core/email_api.php Diff File
mod - docbook/Admin_Guide/en-US/config/email.xml Diff File

MantisBT: master bb5da6b6

2015-04-04 12:17:09

dregad

Details Diff
Use standard HTML5 regex in email_regex_simple()

A future improvement for this would be to retrieve the regex from the
PHPMailer library to ensure we are guaranteed consistent behavior for
our handling of e-mails, but this is currently not possible since the
regexes are hardcoded in PHPMailer's validateAddress() method.

Fixes 0017275, 0017279
mod - core/email_api.php Diff File

MantisBT: master bc195dd5

2015-04-16 17:53:48

dregad

Details Diff
Simplify email validation to only use HTML5 regex

This commit follows the discussion in pull request
https://github.com/mantisbt/mantisbt/pull/172

It basically removes the possibility for the admin to choose between
several e-mail validation methods, and goes back to a simple ON/OFF
setting for $g_validate_email.

Fixes 0017279
mod - config_defaults_inc.php Diff File
mod - core/constant_inc.php Diff File
mod - core/email_api.php Diff File
mod - docbook/Admin_Guide/en-US/config/email.xml Diff File

Issue History

Date Modified Username Field Change
2014-05-02 19:20 grangeway New Issue
2014-05-29 03:29 grangeway Assigned To => grangeway
2014-05-29 03:29 grangeway Status new => assigned
2014-11-07 17:13 atrol Assigned To grangeway =>
2014-11-07 17:13 atrol Status assigned => new
2015-04-16 18:07 dregad Relationship added related to 0017275
2015-04-16 18:08 dregad Relationship added related to 0016894
2015-04-16 18:24 dregad Summary Handling of email addresses within Mantis is not consistent => Email addresses validation and parsing is not consistent
2015-04-16 18:27 dregad Assigned To => dregad
2015-04-16 18:27 dregad Status new => assigned
2015-04-16 18:28 dregad Note Added: 0049426
2015-04-18 19:23 dregad Changeset attached => MantisBT master 3b584404
2015-04-18 19:23 dregad Changeset attached => MantisBT master bb5da6b6
2015-04-18 19:23 dregad Changeset attached => MantisBT master bc195dd5
2015-04-18 19:23 dregad Status assigned => resolved
2015-04-18 19:23 dregad Resolution open => fixed
2015-04-18 19:23 dregad Fixed in Version => 1.3.0-beta.3
2015-04-18 19:25 dregad Target Version => 1.3.0-beta.3
2015-09-06 17:37 vboctoradmin Status resolved => closed