View Issue Details

IDProjectCategoryView StatusLast Update
0017117mantisbtlocalizationpublic2014-12-08 00:34
ReporteraavagyanAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.17 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0017117: Plugin description translation not displayed
Description

On manage_plugin_page.php

When plugin is listed under the "Available Plugins" section it shows its description in the correct language. Once it is installed and relocated to the "Installed Plugins" section it shows its description in English.

TagsNo tags attached.

Activities

dregad

dregad

2014-03-24 13:31

developer   ~0039728

The root cause of this issue is the order in which the various MantisBT APIs are required in core.php. Basically, at the time the installed plugins are initialized, auth_is_user_authenticated() function required by the language subsystem has not yet been declared so the system falls back to default (English).

This problem has been resolved in 1.3.x by the new require_api system introduced by dhx, and the issue is no longer reproducible there.

I'm therefore marking this as resolved, and due to the complexity of the changes and to avoid introducing regressions, I will not backport the changes to 1.2.x.

If this is important to you, as a workaround, feel free to mess around with the order in which the APIs are included in core.php - basically I guess you'd need to move authentication_api.php before database_api.php but there might be additional, cascading dependencies.

aavagyan

aavagyan

2014-03-25 04:46

reporter   ~0039731

This is minor issue and I agree that it is not worth investing so much time, especially if it is already fixed in 1.3.x. Thank you.

Issue History

Date Modified Username Field Change
2014-03-21 17:16 aavagyan New Issue
2014-03-22 02:29 atrol Status new => confirmed
2014-03-24 13:31 dregad Note Added: 0039728
2014-03-24 13:31 dregad Status confirmed => resolved
2014-03-24 13:31 dregad Fixed in Version => 1.3.0-beta.1
2014-03-24 13:31 dregad Resolution open => fixed
2014-03-24 13:31 dregad Assigned To => dregad
2014-03-24 13:32 dregad Target Version => 1.3.0-beta.1
2014-03-25 04:46 aavagyan Note Added: 0039731
2014-12-08 00:34 vboctor Status resolved => closed