View Issue Details

IDProjectCategoryView StatusLast Update
0016463mantisbtbugtrackerpublic2014-12-08 00:34
ReporterdregadAssigned Todregad 
PrioritylowSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.15 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0016463: Sort order defaults to descending
Description

In view all page, when clicking on a column header to sort on this, the sort order defaults to Descending.

It would be more logical to sort in ascending order by default. In fact this is the expected behavior, based on the comment in the code [1]

[1] https://github.com/mantisbt/mantisbt/blob/master-1.2.x/core/print_api.php#L1240

TagsNo tags attached.

Relationships

related to 0003163 closedjfitzell More intuitive sorting when selecting new sort column 

Activities

dregad

dregad

2013-10-08 07:40

developer   ~0038227

Root cause is by assigning sort order to $t_dir variable instead of $p_dir, introduced in https://github.com/mantisbt/mantisbt/commit/6beb5283927bc758bb16c6993ea3d2887d71a521 (see 0003163)

Related Changesets

MantisBT: master 71c7b464

2013-10-08 07:41:29

dregad

Details Diff
Fix 0016463: Sort order defaults to descending

In view all page, when clicking on a column header to sort on it, the
default sort order is now Ascending as expected.
mod - core/print_api.php Diff File

Issue History

Date Modified Username Field Change
2013-10-08 07:34 dregad New Issue
2013-10-08 07:34 dregad Status new => assigned
2013-10-08 07:34 dregad Assigned To => dregad
2013-10-08 07:40 dregad Note Added: 0038227
2013-10-08 07:40 dregad Relationship added related to 0003163
2013-10-09 20:15 dregad Changeset attached => MantisBT master 71c7b464
2013-10-09 20:15 dregad Status assigned => resolved
2013-10-09 20:15 dregad Resolution open => fixed
2013-10-09 20:15 dregad Fixed in Version => 1.3.0-beta.1
2014-12-08 00:34 vboctor Status resolved => closed