View Issue Details

IDProjectCategoryView StatusLast Update
0016331mantisbtdb oraclepublic2014-12-08 00:34
ReporterdregadAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0016331: Attaching file causes ORA-01400: cannot insert NULL into BLOB column
Description

When $g_file_upload_method = DISK, uploading an attachment causes Oracle error 'ORA-01400: cannot insert NULL into ("MANTIS"."M_BUG_FILE_T"."CONTENT")'.

See 0012683:0027934

TagsNo tags attached.

Relationships

related to 0016336 closeddregad File attachment to DB fails when file bigger than 4000 bytes on Oracle 
child of 0013227 closeddregad Oracle DB support multiple issues 

Activities

dregad

dregad

2013-08-27 19:50

developer   ~0037935

Fixed in Oracle branch [1]

[1] https://github.com/dregad/mantisbt/commits/86a37e56491d5d5f6b3649ab565ad255b7635550

miked1234

miked1234

2013-09-18 14:24

reporter  

Error_write_to_db.htm (206,232 bytes)
miked1234

miked1234

2013-09-18 14:24

reporter  

Error_write_to_disk.htm (5,940 bytes)
miked1234

miked1234

2013-09-18 14:24

reporter   ~0038056

I tested the new branch and am still unable to upload to DB or to DISK- see both attached error files. Thank you for your assistance! Mike

dregad

dregad

2013-09-19 04:28

developer   ~0038070

Are you sure you are using the latest HEAD from oracle branch (commit 07264bd8398c36f2866a736076ce54faadc1e309 as I write this) ? I am not able to reproduce the errors you report, both file and db uploads work fine on my dev box.

miked1234

miked1234

2013-09-19 09:16

reporter   ~0038079

I downloaded the link you provided above. Can you give me a specific piece of code I can look for in it that you know is new to the branch?

grangeway

grangeway

2013-09-19 15:59

reporter   ~0038081

Damien,

Are you planning on adding oracle support to the new db layer for 2.x?

I'm trying to remember whether we said we'd keep oracle or drop oracle support in the next release to focus on ensuring that we can test reliably what we do support.

Paul

dregad

dregad

2013-09-19 18:00

developer   ~0038082

Mike - https://github.com/dregad/mantisbt/tree/oracle

Paul - as per an earlier discussion on the subject, I'll work on 2.x when I'm done with 1.3, which will include fixes for Oracle. So to answer your questions, yes I think we should keep Oracle support in. The only issue is that for the time being Travis is not offering Oracle as a platform so automated tests might be more difficult.

miked1234

miked1234

2013-09-24 07:21

reporter   ~0038103

Dregad, I just attempted again with the link you've provided. I am still getting the two errors I attached to this ticket. Thoughts?

Mike

miked1234

miked1234

2013-09-24 07:30

reporter   ~0038104

I just got the disk writing one to work.... I had to drop the not null constraint on M_BUG_FILE_T.CONTENT that existed in the database. It is now working for smaller files.

Related Changesets

MantisBT: master 86da037e

2013-08-27 19:32:23

dregad

Details Diff
Oracle: BLOB columns defaulted to empty_blob()

Fixes an issue preventing insertion of file attachments with
$g_file_upload_method = DISK causing error 'ORA-01400: cannot insert
NULL into ("MANTIS"."M_BUG_FILE_T"."CONTENT")'.

Since I can't do this "properly" without increasing the schema number
(which is not possible in 1.2.x branch), any users encountering this
issue should manually update their schema:

ALTER TABLE M_BUG_FILE_T MODIFY CONTENT DEFAULT empty_blob();
ALTER TABLE M_PROJECT_FILE_T MODIFY CONTENT DEFAULT empty_blob();

Fixes 0016331
mod - admin/schema.php Diff File

Issue History

Date Modified Username Field Change
2013-08-27 19:46 dregad New Issue
2013-08-27 19:46 dregad Status new => assigned
2013-08-27 19:46 dregad Assigned To => dregad
2013-08-27 19:47 dregad Relationship added child of 0013227
2013-08-27 19:50 dregad Note Added: 0037935
2013-08-28 10:55 dregad Relationship added related to 0016336
2013-09-18 14:24 miked1234 File Added: Error_write_to_db.htm
2013-09-18 14:24 miked1234 File Added: Error_write_to_disk.htm
2013-09-18 14:24 miked1234 Note Added: 0038056
2013-09-19 04:28 dregad Note Added: 0038070
2013-09-19 09:16 miked1234 Note Added: 0038079
2013-09-19 15:59 grangeway Note Added: 0038081
2013-09-19 18:00 dregad Note Added: 0038082
2013-09-24 07:21 miked1234 Note Added: 0038103
2013-09-24 07:30 miked1234 Note Added: 0038104
2013-10-17 12:08 dregad Changeset attached => MantisBT master 86da037e
2013-10-17 12:08 dregad Status assigned => resolved
2013-10-17 12:08 dregad Resolution open => fixed
2013-10-17 12:08 dregad Fixed in Version => 1.3.0-beta.1
2013-10-17 12:49 dregad Target Version => 1.3.0-beta.1
2014-04-12 19:39 grangeway Issue cloned: 0017215
2014-12-08 00:34 vboctor Status resolved => closed