View Issue Details

IDProjectCategoryView StatusLast Update
0016330mantisbtdb oraclepublic2014-12-08 00:34
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0016330: html_status_percentage_legend() causes error ORA-00923
Description

When displaying my_view_page.php on Oracle with $g_status_percentage_legend = ON, an SQL error occurs

Database query failed. Error received from database was 923: ORA-00923: FROM keyword not found where expected for the query: SELECT status, COUNT(*) number
FROM m_bug_t
WHERE 1<>1 GROUP BY status.

Additional Information

This occurs with latest trunk of oracle branch (commit 7c0dcd771)

TagsNo tags attached.

Relationships

child of 0013227 closeddregad Oracle DB support multiple issues 

Activities

dregad

dregad

2013-08-27 05:58

developer   ~0037931

This is due to using reserved keyword 'number' to alias the count(*) column.

Related Changesets

MantisBT: master 6bb680b9

2013-08-27 05:59:28

dregad

Details Diff
Don't use reserved SQL keyword as column alias

Using 'number' as alias for column in html_status_percentage_legend()
function causes error ORA-00923 when displaying my_view_page.php on
Oracle.

Fixes 0016330
mod - core/helper_api.php Diff File

Issue History

Date Modified Username Field Change
2013-08-27 05:57 dregad New Issue
2013-08-27 05:57 dregad Relationship added child of 0013227
2013-08-27 05:58 dregad Note Added: 0037931
2013-08-27 05:58 dregad Assigned To => dregad
2013-08-27 05:58 dregad Status new => assigned
2013-10-17 12:08 dregad Changeset attached => MantisBT master 6bb680b9
2013-10-17 12:08 dregad Status assigned => resolved
2013-10-17 12:08 dregad Resolution open => fixed
2013-10-17 12:08 dregad Fixed in Version => 1.3.0-beta.1
2013-10-17 12:49 dregad Target Version => 1.3.0-beta.1
2014-04-12 19:39 grangeway Issue cloned: 0017216
2014-12-08 00:34 vboctor Status resolved => closed