View Issue Details

IDProjectCategoryView StatusLast Update
0016263mantisbtdb mssqlpublic2015-03-15 19:58
ReportermwangAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformSQL Server 2008 R2OSWindows Server 2008 R2OS VersionSP 1
Product Version1.2.15 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0016263: Login Failures Post Installation
Description

The following errors are appearing after attempting to log into Mantis using the default administrator account credentials:

Database query failed. Error received from database was 0008115:
SQLState: 22003
Error Code: 8115
Message: [Microsoft][SQL Server Native Client 11.0][SQL Server]
Arithmetic overflow error converting expression to data type datetime.
SQLState: 01000
Error Code: 3621
Message: [Microsoft][SQL Server Native Client 11.0][SQL Server] The statement has been terminated for the query: DELETE FROM mantis_tokens_table WHERE ? > expiry.

Upon closer inspection of the mantis_tokens_table, the table is empty on installation.

Steps To Reproduce
  1. Install database using the admin/install.php interface.
  2. Attempt to log in using administrator/root.
  3. The error should appear.
Additional Information

On installation, there was an error that was unresolved. I do not know if the details are related to this bug in particular, however, the error that is produced is for Schema DropColumnSQL.

ALTER TABLE mantis_tokens_table DROP CONSTRAINT
ALTER TABLE mantis_tokens_table DROP COLUMN timestamp
SQLState: 42000 Error Code: 102 Message: [Microsoft][SQL Server Native Client 11.0][SQL Server]Incorrect syntax near 'CONSTRAINT'.

TagsNo tags attached.

Activities

dregad

dregad

2013-08-13 18:24

developer   ~0037662

I don't have access to a mssql environment for testing, but if you got errors during install, then the schema is most likely not completely setup, which can explain the fact that MantisBT can't delete from the tokens table. You can confirm this by checking the schema version (check in mantis_config_table for config_id = 'database_version', should be 183)

There are known issues with the ADOdb library's mssqlnative driver which can explain the problem; these are planned to be fixed in MantisBT 1.3.

Until then as a workaround I suggest you generate the SQL and manually install the DB.

grangeway

grangeway

2014-02-17 13:26

reporter   ~0039434

Marking as Suspended

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-03-27 19:12

reporter   ~0039763

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-05-16 15:00

reporter   ~0040321

MantisBT currently supports Mysql and has support for other database engines.

The support for other databases is known to be problematic.

Having implemented the current database layer into Mantis 10 years ago, I'm currently working on replacing the current layer.

If you are interested in using Mantis with non-mysql databases - for example, Oracle, PGSQL or MSSQL, and would be willing to help out testing the new database layer, please drop me an email at paul@mantisforge.org

In the meantime, I'd advise running Mantis with Mysql Only to avoid issues.

Thanks
Paul

dregad

dregad

2015-03-14 14:02

developer   ~0049228

Despite the fact that I am not actually able to test whether the problem is truly resolved since I don't have access to a MSSQL server setup, I'm marking this issue as fixed in 1.3.x on the grounds that the recent updates in ADOdb (which contain many improvements in the MSSQL driver) are likely to address it.

Should the problem persist (using a nightly build or a version > 1.3.0-beta.1), feel free to reopen this issue or to create a new one.

Issue History

Date Modified Username Field Change
2013-08-13 17:45 mwang New Issue
2013-08-13 18:24 dregad Note Added: 0037662
2013-08-13 18:24 dregad Status new => acknowledged
2013-08-13 18:24 dregad View Status private => public
2013-08-14 08:36 MishaMart Issue cloned: 0016265
2013-08-16 04:38 hero2289 Tag Attached: closed
2013-08-16 06:33 atrol Tag Detached: closed
2014-02-17 13:26 grangeway Note Added: 0039434
2014-03-27 19:12 grangeway Note Added: 0039763
2014-03-27 19:12 grangeway Status acknowledged => resolved
2014-03-27 19:12 grangeway Resolution open => suspended
2014-03-27 19:12 grangeway Assigned To => grangeway
2014-03-28 04:18 atrol Status resolved => assigned
2014-04-12 19:33 grangeway Target Version => 1.3.0-beta.1
2014-05-16 15:00 grangeway Note Added: 0040321
2014-05-23 15:08 grangeway Project mantisbt => @24@
2014-11-07 14:36 atrol Assigned To grangeway =>
2014-11-07 14:36 atrol Status assigned => new
2014-11-07 14:36 atrol Project @24@ => mantisbt
2014-12-08 02:10 atrol Target Version 1.3.0-beta.1 => 1.3.0-beta.2
2015-03-14 14:02 dregad Note Added: 0049228
2015-03-14 14:02 dregad Status new => resolved
2015-03-14 14:02 dregad Fixed in Version => 1.3.0-beta.2
2015-03-14 14:02 dregad Resolution suspended => fixed
2015-03-14 14:02 dregad Assigned To => dregad
2015-03-15 19:58 dregad Status resolved => closed