2014-12-18 21:13 EST

View Issue Details Jump to Notes ] Wiki ]
IDProjectCategoryView StatusLast Update
0016072mantisbtemailpublic2013-06-28 16:41
ReporterThomas JACQUES 
Assigned Todregad 
PriorityhighSeveritymajorReproducibilityhave not tried
StatusclosedResolutionunable to reproduce 
PlatformOSUbuntu OS Version10.04.4 LTS
Product Version1.2.15 
Target VersionFixed in Version 
Summary0016072: After a migration 1.0.8 to 1.2.15, mails cannot be send
DescriptionGood morning,

Friday, I migrate Mantis to 1.2.15 .
Nom, I can't send mails.
This is my config_inc.php :

        # Variables du serveur de messagerie
        $g_enable_email_notification = ON;
        $g_phpMailer_method = PHPMAILER_METHOD_SMTP;

        $g_smtp_port = 25;
        $g_smtp_host = 'IP_FROM_INTERNAL_SMTP_SERVER';
        $g_smtp_username = 'mail@domain.fr';
        $g_smtp_password = 'password';

        $g_smtp_connection_mode = '';

        # --- email variables -------------
        $g_administrator_email = 'aa@bb.fr';
        $g_webmaster_email = 'aa@bb.fr';

        # the "From: " field in emails
        $g_from_email = 'aa@bb.fr';

        # the return address for bounced mail
        $g_return_path_email = 'aa@bb.fr';

$g_log_level = LOG_EMAIL | LOG_EMAIL_RECIPIENT;
$g_log_destination = 'file:/tmp/mantisbt.log';

The log_file /tmp/mantisbt.log returns :

19-06-2013 09:42 mail Processing e-mail queue (1 messages)
19-06-2013 09:42 mail Sending message 0000002 queued on 19-06-2013 09:40
19-06-2013 09:42 mail ERROR: Message could not be sent - Erreur SMTP : Echec de l'authentification.

My SMTP_SERVER is OK. I still can send mails with mantis 1.0.8 on the same server.

Please help me.

Thomas.
TagsNo tags attached.
Attached Files

- Relationships
+ Relationships

-  Notes
User avatar

~0037221

dregad (developer)

The error message 'Erreur SMTP : Echec de l'authentification.' is triggered by the phpMailer library, and we just print it out as we get it.

Obviously we're bundling a more recent version of that library in 1.2 than we were in 1.0 which can explain the difference in behavior (I'm assuming here that you have already double-checked that you're using the same parameters for both versions), but the bottomline is that the issue most likely lies with your config settings, I would guess with one of these:

        $g_smtp_username = 'mail@domain.fr';
        $g_smtp_password = 'password';
        $g_smtp_connection_mode = '';

I'm afraid there is not much more I can do. To troubleshoot in more details what is happening behind the scenes, take a look at core/email_api.php email_send() function.

As this issue is linked to your configuration / system setup and not an issue in MantisBT, I'm resolving it now. Use the forums, the mantisbt-help mailing list or IRC for further assistance (refer to http://www.mantisbt.org/support.php [^] for links and further details).
User avatar

~0037222

atrol (developer)

You might also try a nightly build [1] as version 1.2.16dev contains an updated version of the underlying PHPMailer library, see 0015958

[1] http://www.mantisbt.org/builds/ [^]
User avatar

~0037223

Thomas JACQUES (reporter)

Thank you for the answer but config_inc.php doesn't change. Do I have to install something on my server ?
User avatar

~0037224

Thomas JACQUES (reporter)

Hi Atrol,

Thank you for your answer.

How can I Update ?
May I have to dowload all files and copy them in /var/www/mantis/library/phpmailer/ ?

Thomas
User avatar

~0037225

Thomas JACQUES (reporter)

I copied all files in mantisbt-1.2.16dev-master-1.2.x-e73e738\library\phpmailer but I have the same problem :
 php /var/www/mantis/scripts/send_emails.php PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/mcrypt.ini on line 1 in Unknown on line 0
Sending emails...
19-06-2013 14:38 mail Processing e-mail queue (1 messages)
19-06-2013 14:38 mail Sending message 0000002 queued on 19-06-2013 09:40
19-06-2013 14:38 mail ERROR: Message could not be sent - Erreur SMTP : échec de l'authentification.
Done.

The Mantis_email_table didn't existed on Mantis 1.0.8 . Is there a link to my problem ?
User avatar

~0037226

dregad (developer)

Thomas,

There is no direct link. Mantis now uses an e-mail queue, which is what that table is, allowing e-mails to be stored for later sending.

The sending process itself has not changed much, for details see the email_send() function. As I said earlier, the original error is thrown by phpMailer (not by Mantis), as a result of how you define your parameters.
+  Notes

- Issue History
Date Modified Username Field Change
2013-06-19 05:12 Thomas JACQUES New Issue
2013-06-19 07:44 dregad Note Added: 0037221
2013-06-19 07:44 dregad Status new => resolved
2013-06-19 07:44 dregad Resolution open => unable to reproduce
2013-06-19 07:44 dregad Assigned To => dregad
2013-06-19 08:20 atrol Note Added: 0037222
2013-06-19 08:28 Thomas JACQUES Note Added: 0037223
2013-06-19 08:38 Thomas JACQUES Note Added: 0037224
2013-06-19 08:53 Thomas JACQUES Note Added: 0037225
2013-06-19 12:57 dregad Note Added: 0037226
2013-06-28 16:41 atrol Status resolved => closed
+ Issue History