View Issue Details

IDProjectCategoryView StatusLast Update
0016029mantisbtpreferencespublic2014-12-08 00:34
ReporterdregadAssigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.15 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0016029: Impossible to copy columns to/from a subproject when parent is selected
Description

In the manage columns page, it is not possible to copy the columns to or from a subproject, when the current project is the parent project, because the selection list completely removes the whole subtree instead of just the current project.

TagsNo tags attached.

Activities

dregad

dregad

2013-06-07 09:51

developer   ~0037138

In addition, the code does not disable 'All Projects' when the current project is the same.

Related Changesets

MantisBT: master b3d06a3d

2013-06-07 09:58:47

dregad

Details Diff
Can't copy columns to/from subproject when parent is current

In the manage columns page, it is not possible to copy the columns to or
from a subproject, when the current project is the parent project,
because the selection list completely removes the whole subtree instead
of just the current project.

In addition, we now also don't print 'All Projects' anymore when the
current project is the same.

Fixes 0016029

Conflicts:
core/print_api.php
mod - core/print_api.php Diff File

MantisBT: master d88d0163

2013-06-07 15:58:47

dregad

Details Diff
Can't copy columns to/from subproject when parent is current

In the manage columns page, it is not possible to copy the columns to or
from a subproject, when the current project is the parent project,
because the selection list completely removes the whole subtree instead
of just the current project.

In addition, we now also don't print 'All Projects' anymore when the
current project is the same.

Fixes 0016029
mod - core/print_api.php Diff File

Issue History

Date Modified Username Field Change
2013-06-07 09:44 dregad New Issue
2013-06-07 09:44 dregad Status new => assigned
2013-06-07 09:44 dregad Assigned To => dregad
2013-06-07 09:51 dregad Note Added: 0037138
2013-10-09 11:03 dregad Changeset attached => MantisBT master b3d06a3d
2013-10-09 11:03 dregad Status assigned => resolved
2013-10-09 11:03 dregad Resolution open => fixed
2013-10-09 11:03 dregad Fixed in Version => 1.3.0-beta.1
2013-10-09 12:43 dregad Target Version 1.2.16 => 1.3.0-beta.1
2013-10-11 23:23 dregad Changeset attached => MantisBT master d88d0163
2013-10-18 17:10 atrol Product Version 1.2.16 => 1.2.15
2014-12-08 00:34 vboctor Status resolved => closed