View Issue Details

IDProjectCategoryView StatusLast Update
0016026mantisbtfeaturepublic2014-12-08 00:34
ReporterChewitsAssigned Todregad 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0016026: Use the 'Default project' when reporting a new bug
Description

It would be nice if we used the 'Default project' (My Account->Preferences) as a 'default' when creating new issue in the case when:
Active project == 'All projects' && Default project != 'All projects'

TagsNo tags attached.

Activities

dregad

dregad

2013-06-07 10:35

developer   ~0037142

Test this https://github.com/dregad/mantisbt/tree/fix-16024

Chewits

Chewits

2013-06-07 11:08

reporter   ~0037143

Thanks!
Please try this:

  1. Relogin
  2. Select 'All Projects' as active project and click 'Switch'
  3. Click 'Report Issue'

In this case I see the first available project selected, not 'Default project'. Maybe that's my problem because I have the similar issue:

  1. My Account->Preferencies->Set 'Test Project' as Default
  2. Relogin

In this case I actually have 'Test Project' as active, but 'All Projects' is shown at the top right drop-down menu. Note that with the www.mantisbt.org all is Ok. Could this be issue related to web-server configuration (caching)?

Chewits

Chewits

2013-06-07 11:34

reporter   ~0037145

Sorry, I have not noticed the last commit! Now this works fine for me.

Related Changesets

MantisBT: master 116dfbfb

2013-06-07 16:30:10

dregad

Details Diff
Use the 'Default project' when reporting a new bug

When reporting a new issue, if the current project is ALL_PROJECTS and
the user's default project is not ALL_PROJECTS, then we automatically
switch to the user's default project instead of displaying the selection
list.

Fixes 0016026
mod - bug_report_page.php Diff File

Issue History

Date Modified Username Field Change
2013-06-07 06:08 Chewits New Issue
2013-06-07 10:35 dregad Note Added: 0037142
2013-06-07 10:35 dregad Assigned To => dregad
2013-06-07 10:35 dregad Status new => feedback
2013-06-07 11:08 Chewits Note Added: 0037143
2013-06-07 11:08 Chewits Status feedback => assigned
2013-06-07 11:34 Chewits Note Added: 0037145
2013-10-11 23:23 dregad Changeset attached => MantisBT master 116dfbfb
2013-10-11 23:23 dregad Status assigned => resolved
2013-10-11 23:23 dregad Resolution open => fixed
2013-10-11 23:23 dregad Fixed in Version => 1.3.0-beta.1
2013-10-12 01:52 dregad Target Version => 1.3.0-beta.1
2014-12-08 00:34 vboctor Status resolved => closed