View Issue Details

IDProjectCategoryView StatusLast Update
0015699mantisbtdb postgresqlpublic2014-12-08 00:34
ReporternathandAssigned Todregad 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformPosgres 8.4.7OSRedhatOS Version5.9
Product Version1.2.14 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0015699: Upgrade 1.2.10 to 1.2.14 Issues
Description

I tried to upgrade of Mantis Instance and got the following error for the my_view_page.php and view_all_bug_page.php pages:

Database query failed. Error received from database was #-1: ERROR: operator does not exist: integer = boolean at character 220
HINT: No operator matches the given name and argument type(s). You might need to add explicit type casts. for the query:
SELECT DISTINCT cft.id
FROM mantis_custom_field_table cft
JOIN mantis_custom_field_project_table cfpt ON cfpt.field_id = cft.id
JOIN mantis_project_table pt
ON pt.id = cfpt.project_id AND pt.enabled = true
LEFT JOIN mantis_project_user_list_table pult
ON pult.project_id = cfpt.project_id AND pult.user_id = ?
, mantis_user_table ut
WHERE ut.id = ?
AND ( pt.view_state = 10
OR pult.user_id = ut.id
OR ( pult.user_id IS NULL AND ut.access_level >=? ) ).

Never had any issues upgrading before.....

Additional Information

Report Issue is also not showing a full form, but only giving us the "Choose Project" Option.

TagsNo tags attached.

Relationships

child of 0014398 closeddregad Support for PostgreSQL broken in 1.3 

Activities

atrol

atrol

2013-04-01 14:50

developer   ~0036007

nathand,

I was not able to reproduce your problem.
Did you exactly follow the steps described at:
http://www.mantisbt.org/docs/master-1.2.x/en/administration_guide.html#ADMIN.INSTALL.UPGRADE

Additional information listed below may also be useful:

  • Exact version of PHP
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
grangeway

grangeway

2013-04-05 17:22

reporter   ~0036059

Postgresql support is known-broken in the 1.2.x releases - due to adodb.

We have replaced the db layer in our 2.x branches to allow us to fix support for postgres/mssql. For now, I would suggest staying on the working 1.2.10 release.

Paul

gfantone

gfantone

2013-08-06 08:46

reporter   ~0037631

i have same problem with 1.2.15 but one solution
try :

create or replace function bool_to_smallint (boolean)
returns integer
strict
language sql as '
select case
when $1 then 1
else 0
end;
';

create cast (boolean as integer)
with function bool_to_smallint(boolean)
as implicit;

dregad

dregad

2014-02-24 15:28

developer   ~0039515

There were several cases of type mismatch (int vs boolean) in 1.2.x - these should now be fixed in master branch.

Please try to reproduce the problem using a nightly build, and feel free to reopen this issue if the error still occurs.

Issue History

Date Modified Username Field Change
2013-03-31 17:24 nathand New Issue
2013-04-01 14:50 atrol Note Added: 0036007
2013-04-01 14:50 atrol Status new => feedback
2013-04-05 17:22 grangeway Note Added: 0036059
2013-04-05 17:22 grangeway Status feedback => resolved
2013-04-05 17:22 grangeway Resolution open => won't fix
2013-04-05 17:22 grangeway Assigned To => grangeway
2013-04-06 07:21 grangeway Status resolved => acknowledged
2013-04-06 09:55 dregad Status acknowledged => resolved
2013-04-27 16:32 atrol Assigned To grangeway =>
2013-04-27 16:32 atrol Status resolved => feedback
2013-04-27 16:32 atrol Resolution won't fix => open
2013-04-27 16:32 atrol Category upgrade => db postgresql
2013-07-30 06:51 dregad Relationship added child of 0014398
2013-08-06 08:46 gfantone Note Added: 0037631
2013-08-14 08:36 MishaMart Issue cloned: 0016305
2013-08-16 04:38 hero2289 Tag Attached: closed
2013-08-16 06:33 atrol Tag Detached: closed
2014-02-24 15:28 dregad Note Added: 0039515
2014-02-24 15:29 dregad Assigned To => dregad
2014-02-24 15:29 dregad Status feedback => resolved
2014-02-24 15:29 dregad Resolution open => fixed
2014-02-24 15:29 dregad Fixed in Version => 1.3.0-beta.1
2014-02-24 15:29 dregad Target Version => 1.3.0-beta.1
2014-12-08 00:34 vboctor Status resolved => closed