MantisBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0015667mantisbtcustom fieldspublic2013-03-19 05:182013-04-17 17:42
Reportervovella 
Assigned Toatrol 
PriorityhighSeveritytweakReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version1.2.14 
Target VersionFixed in Version 
Summary0015667: Filter bad work with a blank cell in custom field
DescriptionIn custom field when select a blank cell and then filtering, result will be wrong. In table will be show 5 issues, but in real their is 9.

All other options in filter make show all.
Steps To ReproduceMake some custom field |1|2|3

Make some issues with this custom field with selected one from any choose cell (some issues need with a blank cell in cutom field)

Filtering issues by a blank cell of custom field.
TagsNo tags attached.
Attached Filespng file icon blank cell.png [^] (158,711 bytes) 2013-03-19 05:18
png file icon property_custom_field.png [^] (61,611 bytes) 2013-03-19 05:18


png file icon blank cell-eng.png [^] (176,314 bytes) 2013-03-19 08:23
png file icon property_custom_field-eng.png [^] (71,734 bytes) 2013-03-19 08:25

- Relationships
duplicate of 0004864new Unable to filter on empty custom field value 

-  Notes
User avatar (0035911)
vovella (reporter)
2013-03-19 05:23

By the way, if select a blank cell and filtering, fied will be show that selected "any", but need show a blank cell.
User avatar (0035912)
atrol (developer)
2013-03-19 05:29

Please attach also screenshots with English language settings.
User avatar (0035913)
vovella (reporter)
2013-03-19 08:25

Done.
User avatar (0035915)
vovella (reporter)
2013-03-19 13:04

Can't access this patch http://git.mantisforge.org/w/mantisbt/gtz-et.git?a=shortlog;h=refs/heads/mantisbt-issue11476 [^] [^]
User avatar (0035922)
atrol (developer)
2013-03-20 03:23

I asked at our developer mailing list to activate mantisforge.org.
http://sourceforge.net/mailarchive/message.php?msg_id=30619244 [^]
User avatar (0035945)
vovella (reporter)
2013-03-21 06:59

Okay. I'll waiting...
User avatar (0036009)
vovella (reporter)
2013-04-02 00:39

I can't access to path. Problem is not resolved! :(
User avatar (0036014)
atrol (developer)
2013-04-02 15:29

Sorry, there is nothing I can do for you at this place.
Therefore I will set this issue to resolved again.
I added you to the monitoring list of the duplicate issue.

You can try also other support channels http://www.mantisbt.org/support.php [^]
Try to speak to user paulr at IRC (AFAIK mantisforge.org is his private server) and/or write to the mantisbt-help mailing list
http://www.mantisbt.org/mailinglists.php [^]

- Issue History
Date Modified Username Field Change
2013-03-19 05:18 vovella New Issue
2013-03-19 05:18 vovella File Added: blank cell.png
2013-03-19 05:18 vovella File Added: property_custom_field.png
2013-03-19 05:23 vovella Note Added: 0035911
2013-03-19 05:29 atrol Note Added: 0035912
2013-03-19 08:23 vovella File Added: blank cell-eng.png
2013-03-19 08:25 vovella File Added: property_custom_field-eng.png
2013-03-19 08:25 vovella Note Added: 0035913
2013-03-19 12:57 atrol Relationship added has duplicate 0004864
2013-03-19 12:57 atrol Relationship replaced duplicate of 0004864
2013-03-19 12:57 atrol Status new => resolved
2013-03-19 12:57 atrol Resolution open => duplicate
2013-03-19 12:57 atrol Assigned To => atrol
2013-03-19 13:04 vovella Note Added: 0035915
2013-03-20 03:23 atrol Note Added: 0035922
2013-03-21 06:59 vovella Note Added: 0035945
2013-04-01 15:46 atrol Status resolved => closed
2013-04-02 00:39 vovella Note Added: 0036009
2013-04-02 00:39 vovella Status closed => feedback
2013-04-02 00:39 vovella Resolution duplicate => reopened
2013-04-02 15:29 atrol Note Added: 0036014
2013-04-02 15:29 atrol Status feedback => resolved
2013-04-02 15:29 atrol Resolution reopened => duplicate
2013-04-06 07:21 grangeway Status resolved => acknowledged
2013-04-06 09:55 dregad Status acknowledged => resolved
2013-04-17 17:42 atrol Status resolved => closed


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.0886 seconds.
memory usage: 3,081 KB
Powered by Mantis Bugtracker