View Issue Details

IDProjectCategoryView StatusLast Update
0015427mantisbtdb mssqlpublic2014-12-08 00:34
ReporterefreyAssigned Todregad 
PrioritynoneSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version1.2.12 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0015427: Deploy mantis with MSSQL and UTF8
Description

I have deployed a mantisbt instance for issue manage. and since it's WW project, globalization is a MUST option. and the environment is Microsoft IIS7.5 as web server and MS SQLSERVER 2008 R2 as database with MSSQL native driver.

There are many errors in the database scripts when install.php was requested.
after corrected these script errors I realized that it didn't support utf-8 with MS SQL perfect even change varchar to nvarchar and text to ntext.

After many test, I changed the next column to nvarchar(max), and modified the php file:
library\adodb\drivers\adodb-mssqlnative.inc.php
find below function:
function _connect($argHostname, $argUsername, $argPassword, $argDatabasename)
and add ,'CharacterSet'=>'UTF-8' to $connectionInfo variable:
$connectionInfo = array("Database"=>$argDatabasename,'UID'=>$argUsername,'PWD'=>$argPassword,'CharacterSet'=>'UTF-8');

finally, it works well.

TagsNo tags attached.

Relationships

related to 0009809 new I cannot use Korean on Mantis v1.1.4 
related to 0013713 closeddregad Upgrade ADOdb library to latest version 

Activities

dregad

dregad

2013-01-28 04:28

developer   ~0034928

efrey,

Thanks for the bug report. Based on your description, the problem seems to be not with Mantis, but with the underlying ADOdb library. Please note that this is not maintained by us, we just bundle it.

That the ADOdb version packaged with MantisBT 1.2.12 is quite outdated (it's a custom-patched 5.10). I am planning to upgrade that at some point (see 0013713), but don't know when it will actually happen.

Considering that there have been many improvements in the mssqlnative ADOdb driver since 5.10, I recommend that you download the latest version (5.18) [1] and see if it works.

If not, please file a bug report on the ADOdb support forum [2] and attach a link to it here.

[1] http://sourceforge.net/projects/adodb/files/adodb-php5-only/
[2] http://phplens.com/lens/lensforum/topics.php?id=4

efrey

efrey

2013-01-28 09:55

reporter   ~0034934

dregad,
Thanks for the reply. In fact the issue has been resolved in my case (the ms sql native driver is the latest one).
What I want to say is it would be better for mantis under windows platform (IIS + MS SQL) if:

  1. provide n-type fields db schema script for MS SQL on install.php
  2. include CharacterSet=UTF8 on the connect method.

maybe this will cause other drivers issue? I don't know...

dregad

dregad

2013-01-28 10:47

developer   ~0034935

As I said before, MantisBT relies on an underlying library (ADOdb) for all database operations. There is no way to achieve what you say, without changing ADOdb.

So if you want it fixed, you need to report it upstream.

Issue History

Date Modified Username Field Change
2013-01-26 02:14 efrey New Issue
2013-01-26 03:36 atrol Relationship added related to 0009809
2013-01-28 04:28 dregad Note Added: 0034928
2013-01-28 04:28 dregad Status new => acknowledged
2013-01-28 04:29 dregad Relationship added related to 0013713
2013-01-28 09:55 efrey Note Added: 0034934
2013-01-28 10:47 dregad Note Added: 0034935
2013-10-17 12:30 dregad Status acknowledged => resolved
2013-10-17 12:30 dregad Fixed in Version => 1.3.0-beta.1
2013-10-17 12:30 dregad Resolution open => fixed
2013-10-17 12:30 dregad Assigned To => dregad
2013-10-17 12:58 dregad Target Version => 1.3.0-beta.1
2014-12-08 00:34 vboctor Status resolved => closed