View Issue Details

IDProjectCategoryView StatusLast Update
0015426mantisbtdb oraclepublic2014-12-08 00:34
ReporterdregadAssigned Todregad 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.12 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0015426: GetRowAssoc fails with Oracle DB
Description

With Oracle, calls to GetRowAssoc(0) fail to return data in the
associative array (all fields are set to null), even in latest version of AdoDB (5.18). This is due to MantisBT defaulting to ADODB_FETCH_ASSOC fetch mode, and the fact that Oracle returns uppercase column names in the recordset.

TagsNo tags attached.

Relationships

related to 0009314 closeddregad ADODB GetRowAssoc does not work 
child of 0013227 closeddregad Oracle DB support multiple issues 

Activities

dregad

dregad

2013-01-25 10:38

developer   ~0034916

Last edited: 2013-01-25 12:23

View 2 revisions

I have submitted a patch [1] upstream [2]. Until this gets implemented, we work around the issue by setting ADODB_FETCH_MODE = ADODB_FETCH_NUM for Oracle in db_connect().

EDIT: this issue actually does NOT exist in the current Oracle branch, it was fixed in an earlier commit, setting fetch mode to ADODB_FETCH_BOTH; this will be replaced with ADODB_FETCH_NUM, which is more efficient (lower memory footprint).

Related Changesets

MantisBT: master 42152ec0

2013-01-28 09:06:33

dregad

Details Diff
Change ADOdb fetch mode to ADODB_FETCH_NUM for Oracle

We were previously using ADODB_FETCH_BOTH, which is less efficient as
each field is returned twice in the recordset. Using ADODB_FETCH_NUM
reduces the memory footprint.

This is a workaround for issue 0015426, allowing MantisBT to function
until ADOdb library is patched to fix the problem's root cause.
mod - core/database_api.php Diff File

MantisBT: master 84d21a61

2014-05-13 03:23:20

dregad

Details Diff
oci8 no longer needs special fetch mode with ADOdb 5.19

Fixes 0015426
mod - core/database_api.php Diff File

Issue History

Date Modified Username Field Change
2013-01-25 10:36 dregad New Issue
2013-01-25 10:38 dregad Note Added: 0034916
2013-01-25 10:38 dregad Status new => confirmed
2013-01-25 10:38 dregad Additional Information Updated View Revisions
2013-01-25 10:39 dregad Relationship added child of 0013227
2013-01-25 10:39 dregad Relationship added related to 0009314
2013-01-25 12:21 dregad Additional Information Updated View Revisions
2013-01-25 12:23 dregad Note Edited: 0034916 View Revisions
2013-10-17 12:08 dregad Changeset attached => MantisBT master 42152ec0
2013-10-17 12:29 dregad Status confirmed => resolved
2013-10-17 12:29 dregad Fixed in Version => 1.3.0-beta.1
2013-10-17 12:29 dregad Resolution open => fixed
2013-10-17 12:29 dregad Assigned To => dregad
2013-10-17 12:49 dregad Target Version => 1.3.0-beta.1
2014-04-12 19:39 grangeway Issue cloned: 0017217
2014-05-13 06:59 dregad Changeset attached => MantisBT adodb 882b2a88
2014-05-13 07:04 dregad Changeset removed MantisBT adodb 882b2a88 =>
2014-07-10 03:38 dregad Changeset attached => MantisBT master 84d21a61
2014-12-08 00:34 vboctor Status resolved => closed