View Issue Details

IDProjectCategoryView StatusLast Update
0015281mantisbtbugtrackerpublic2017-12-04 02:25
ReporterdregadAssigned Tosyncguru 
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Product Version1.2.13 
Target Version2.10.0Fixed in Version 
Summary0015281: Consistent user interface for date fields
Description

Currently in Mantis we have several different ways of entering dates for both data entry and filters (e.g. text field + jscalendar or day+month+year select fields).

We should use a consistent UI throughout the application.

TagsNo tags attached.

Relationships

parent of 0015276 assignedsyncguru Custom field "Date" 31 days every month. 
parent of 0004454 assignedsyncguru 31 February ??? 
parent of 0008957 assignedsyncguru Date Selector for Custom Fields 
parent of 0015257 closeddregad Inconsistent use of numeric vs text month in date filter selection fields 
parent of 0020040 closedsyncguru Replace jscalendar by a newer widget 
parent of 0021873 assignedsyncguru Use datetime picker for date ranges in filter 
parent of 0021874 assignedsyncguru Use datetime picker for date ranges in time tracking 
related to 0019462 closeddregad Default date jscalendar 
Not all the children of this issue are yet resolved or closed.

Activities

atrol

atrol

2017-03-30 16:20

developer   ~0056288

Set to resolved as all child issues are resolved.

cproensa

cproensa

2017-04-16 18:45

developer   ~0056587

Reopened. Due to regressions, the changes have been reverted and will be targeted to next release

Issue History

Date Modified Username Field Change
2012-12-12 10:54 dregad New Issue
2012-12-12 10:54 dregad Status new => confirmed
2012-12-12 10:56 dregad Relationship added parent of 0015276
2012-12-12 10:56 dregad Relationship added parent of 0004454
2012-12-12 10:57 dregad Relationship added parent of 0008957
2012-12-12 11:00 dregad Relationship added parent of 0015257
2014-01-21 18:51 atrol Target Version 1.3.0-beta.1 =>
2015-03-03 03:46 dregad Relationship added related to 0019462
2015-08-10 12:43 dregad Relationship added related to 0019943
2015-08-17 15:58 atrol Relationship added related to 0020040
2015-08-17 15:58 atrol Relationship deleted related to 0019943
2016-12-20 12:53 dregad Relationship added parent of 0021873
2016-12-20 12:53 dregad Relationship added parent of 0021874
2016-12-20 12:54 dregad Relationship replaced parent of 0020040
2017-03-30 16:20 atrol Assigned To => syncguru
2017-03-30 16:20 atrol Status confirmed => resolved
2017-03-30 16:20 atrol Fixed in Version => 2.3.0
2017-03-30 16:20 atrol Target Version => 2.3.0
2017-03-30 16:20 atrol Note Added: 0056288
2017-04-01 00:13 vboctoradmin Status resolved => closed
2017-04-16 18:45 cproensa Status closed => assigned
2017-04-16 18:45 cproensa Note Added: 0056587
2017-04-16 18:45 cproensa Fixed in Version 2.3.0 =>
2017-04-16 18:45 cproensa Target Version 2.3.0 => 2.4.0
2017-04-30 14:53 vboctoradmin Target Version 2.4.0 => 2.5.0
2017-06-04 16:19 atrol Target Version 2.5.0 => 2.6.0
2017-09-03 18:50 vboctor Target Version 2.6.0 => 2.7.0
2017-10-08 23:55 vboctor Target Version 2.7.0 => 2.8.0
2017-10-28 19:14 vboctor Target Version 2.8.0 => 2.9.0
2017-12-04 02:25 vboctor Target Version 2.9.0 => 2.10.0