View Issue Details

IDProjectCategoryView StatusLast Update
0014395mantisbtdb mssqlpublic2015-03-15 19:58
ReporterAlyndriAssigned Todregad 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformGoogle ChromeOSWinXPOS Version-
Product Version1.2.10 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0014395: Critical Failure when Assigning Tags to Multiple Issues at Once
Description

Database error after attaching tags to multiple issues from the 'view issues' page

Steps To Reproduce
  1. go to 'view issues' page

  2. select multiple issues

  3. choose 'attach tags' from dropdown box

  4. type in a tag and choose 'attach'

  5. select any issue (even one that has not had a tag attached)

  6. database error displayed (attached)
TagsNo tags attached.

Relationships

related to 0011744 closedrombert Failure getting tag candidates on MSSQL 
related to 0014441 acknowledged view.php - Tag Selection Dropdown only shows 'Exisiting Tags' but none of the actual tags in existence 

Activities

Alyndri

Alyndri

2012-06-18 17:30

reporter  

tag error.JPG (30,937 bytes)
tag error.JPG (30,937 bytes)
atrol

atrol

2012-06-19 02:31

developer   ~0032117

Do you use MSSQL databse?

Alyndri

Alyndri

2012-06-19 23:09

reporter   ~0032118

Hi Atrol, yes, this is implemented into MSSQL. is it a problem related to this?

atrol

atrol

2012-06-20 02:11

developer   ~0032119

this is implemented into MSSQL. is it a problem related to this?
I am quite sure it is because
a) I am not able to reproduce the issue using MySQL and
b) There have been similiar issues, see related 0011744

grangeway

grangeway

2014-02-17 13:26

reporter   ~0039445

Marking as Suspended

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-03-27 19:12

reporter   ~0039757

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-05-16 15:00

reporter   ~0040328

MantisBT currently supports Mysql and has support for other database engines.

The support for other databases is known to be problematic.

Having implemented the current database layer into Mantis 10 years ago, I'm currently working on replacing the current layer.

If you are interested in using Mantis with non-mysql databases - for example, Oracle, PGSQL or MSSQL, and would be willing to help out testing the new database layer, please drop me an email at paul@mantisforge.org

In the meantime, I'd advise running Mantis with Mysql Only to avoid issues.

Thanks
Paul

dregad

dregad

2015-03-14 14:02

developer   ~0049230

Despite the fact that I am not actually able to test whether the problem is truly resolved since I don't have access to a MSSQL server setup, I'm marking this issue as fixed in 1.3.x on the grounds that the recent updates in ADOdb (which contain many improvements in the MSSQL driver) are likely to address it.

Should the problem persist (using a nightly build or a version > 1.3.0-beta.1), feel free to reopen this issue or to create a new one.

Issue History

Date Modified Username Field Change
2012-06-18 17:30 Alyndri New Issue
2012-06-18 17:30 Alyndri File Added: tag error.JPG
2012-06-19 02:30 atrol Relationship added related to 0011744
2012-06-19 02:31 atrol Note Added: 0032117
2012-06-19 02:31 atrol Status new => feedback
2012-06-19 23:09 Alyndri Note Added: 0032118
2012-06-19 23:09 Alyndri Status feedback => new
2012-06-20 02:10 atrol Category tagging => db mssql
2012-06-20 02:11 atrol Note Added: 0032119
2012-07-02 12:00 dregad Relationship added related to 0014441
2014-02-17 13:26 grangeway Note Added: 0039445
2014-03-27 19:12 grangeway Note Added: 0039757
2014-03-27 19:12 grangeway Status new => resolved
2014-03-27 19:12 grangeway Resolution open => suspended
2014-03-27 19:12 grangeway Assigned To => grangeway
2014-03-28 04:18 atrol Status resolved => assigned
2014-04-12 19:33 grangeway Target Version => 1.3.0-beta.1
2014-05-16 15:00 grangeway Note Added: 0040328
2014-05-23 15:08 grangeway Project mantisbt => @24@
2014-11-07 14:33 atrol Assigned To grangeway =>
2014-11-07 14:33 atrol Status assigned => new
2014-11-07 14:33 atrol Project @24@ => mantisbt
2014-12-08 02:10 atrol Target Version 1.3.0-beta.1 => 1.3.0-beta.2
2015-03-14 14:02 dregad Note Added: 0049230
2015-03-14 14:02 dregad Status new => resolved
2015-03-14 14:02 dregad Fixed in Version => 1.3.0-beta.2
2015-03-14 14:02 dregad Resolution suspended => fixed
2015-03-14 14:02 dregad Assigned To => dregad
2015-03-15 19:58 dregad Status resolved => closed