View Issue Details

IDProjectCategoryView StatusLast Update
0013906mantisbtdb mssqlpublic2015-03-15 19:58
ReporterportalsoftAssigned Todregad 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindows Server 2008OS VersionR2 Enterprise
Product Version1.2.9 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0013906: Application error on manage_proj_edit_page.php
Description

When a project name is clicked on Manage Projects page, the following error message appears:

APPLICATION ERROR 0000401
Database query failed. Error received from database was #0: [Microsoft][ODBC SQL Server Driver]Invalid parameter number for the query: SELECT DISTINCT u.id, u.username, u.realname
FROM mantis_user_table u
LEFT JOIN mantis_project_user_list_table p
ON p.user_id=u.id AND p.project_id=?
WHERE u.access_level<? AND
u.enabled = ? AND
p.user_id IS NULL
ORDER BY u.realname, u.username.

Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

Steps To Reproduce

Login to Mantis
Create a new project
Go to Manage page (main menu -> Manage link)
Click on the link of the newly created project
-> Application Error 0000401

Additional Information

Environment:

  • Windows Server 2008 R2 (build 7601: service pack 1)
  • IIS 7.5 (7.5.7600.16385)
  • MSSQL Server 2008
  • PHP 5.3 (php-5.3.10-nts-Win32-VC9-x86)
  • PHP MSSQL driver (SQLSRV20)
  • mantis 1.2.8-master (mantisbt-1.2.8-master-1.2.x-5e9ead3)
TagsNo tags attached.

Relationships

related to 0012674 closeddregad APPLICATION ERROR 0000401 on manage_user_edit_page.php and other occasions 
has duplicate 0016127 closedatrol occurs error when executing edit project 

Activities

Jepolis

Jepolis

2013-08-02 03:41

reporter   ~0037589

Try the patch found here: http://www.mantisbt.org/bugs/view.php?id=12674

grangeway

grangeway

2014-02-17 13:26

reporter   ~0039436

Marking as Suspended

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-03-27 19:12

reporter   ~0039765

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-05-16 15:00

reporter   ~0040323

MantisBT currently supports Mysql and has support for other database engines.

The support for other databases is known to be problematic.

Having implemented the current database layer into Mantis 10 years ago, I'm currently working on replacing the current layer.

If you are interested in using Mantis with non-mysql databases - for example, Oracle, PGSQL or MSSQL, and would be willing to help out testing the new database layer, please drop me an email at paul@mantisforge.org

In the meantime, I'd advise running Mantis with Mysql Only to avoid issues.

Thanks
Paul

dregad

dregad

2015-03-14 14:02

developer   ~0049221

Despite the fact that I am not actually able to test whether the problem is truly resolved since I don't have access to a MSSQL server setup, I'm marking this issue as fixed in 1.3.x on the grounds that the recent updates in ADOdb (which contain many improvements in the MSSQL driver) are likely to address it.

Should the problem persist (using a nightly build or a version > 1.3.0-beta.1), feel free to reopen this issue or to create a new one.

Issue History

Date Modified Username Field Change
2012-02-16 10:26 portalsoft New Issue
2012-02-20 11:45 dregad Status new => acknowledged
2012-02-20 11:45 dregad Product Version git trunk => 1.2.9
2013-07-02 02:46 atrol Relationship added has duplicate 0016127
2013-08-02 03:41 Jepolis Note Added: 0037589
2013-08-02 03:46 atrol Relationship added related to 0012674
2013-08-16 04:38 hero2289 Tag Attached: closed
2013-08-16 06:33 atrol Tag Detached: closed
2014-02-17 13:26 grangeway Note Added: 0039436
2014-03-27 19:12 grangeway Note Added: 0039765
2014-03-27 19:12 grangeway Status acknowledged => resolved
2014-03-27 19:12 grangeway Resolution open => suspended
2014-03-27 19:12 grangeway Assigned To => grangeway
2014-03-28 04:18 atrol Status resolved => assigned
2014-04-12 19:33 grangeway Target Version => 1.3.0-beta.1
2014-05-16 15:00 grangeway Note Added: 0040323
2014-05-23 15:08 grangeway Project mantisbt => @24@
2014-11-07 14:31 atrol Assigned To grangeway =>
2014-11-07 14:31 atrol Status assigned => new
2014-11-07 14:32 atrol Project @24@ => mantisbt
2014-12-08 02:10 atrol Target Version 1.3.0-beta.1 => 1.3.0-beta.2
2015-03-14 14:02 dregad Note Added: 0049221
2015-03-14 14:02 dregad Status new => resolved
2015-03-14 14:02 dregad Fixed in Version => 1.3.0-beta.2
2015-03-14 14:02 dregad Resolution suspended => fixed
2015-03-14 14:02 dregad Assigned To => dregad
2015-03-15 19:58 dregad Status resolved => closed