View Issue Details

IDProjectCategoryView StatusLast Update
0013905mantisbtdb mssqlpublic2015-03-15 19:58
ReporterportalsoftAssigned Todregad 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindows Server 2008OS VersionR2 Enterprise
Product Version1.2.9 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0013905: Application Error 0000401 on summary_page.php
Description

When Summary link on main menu is clicked, the following error message appears:

APPLICATION ERROR 0000401

Database query failed. Error received from database was #0: [Microsoft][ODBC SQL Server Driver]Invalid parameter number for the query: SELECT b.id, b.date_submitted, b.last_updated, MAX(h.date_modified) as hist_update, b.status
FROM mantis_bug_table b LEFT JOIN mantis_bug_history_table h
ON b.id = h.bug_id AND h.type=0 AND h.field_name='status' AND h.new_value=?
WHERE b.status >=? AND project_id=1
GROUP BY b.id, b.status, b.date_submitted, b.last_updated
ORDER BY b.id ASC.

Steps To Reproduce

Login to Mantis
Report two issues
Go to Summary page (main menu -> Summary link)
-> Application Error 0000401

Additional Information

Environment:

  • Windows Server 2008 R2 (build 7601: service pack 1)
  • IIS 7.5 (7.5.7600.16385)
  • MSSQL Server 2008
  • PHP 5.3 (php-5.3.10-nts-Win32-VC9-x86)
  • PHP MSSQL driver (SQLSRV20)
  • mantis 1.2.8-master (mantisbt-1.2.8-master-1.2.x-5e9ead3)
TagsNo tags attached.

Relationships

has duplicate 0014352 closedatrol Summary Error 401 

Activities

herick.marques

herick.marques

2012-12-11 07:18

reporter   ~0034527

Same error here.

APPLICATION ERROR 0000401
Database query failed. Error received from database was
#-1:ERROR: column "b.category_id" must appear in the GROUP BY clause
or be used in an aggregate function" para a consulta: "SELECT
COUNT(b.id) as bugcount, c.name AS category_name, category_id,
b.status
FROM mantis_bug_table b
JOIN mantis_category_table AS c ON b.category_id=c.id
WHERE b.project_id=1
GROUP BY c.name, b.status
ORDER BY c.name"

Environment:

  • Ubuntu 12.04 LTS
  • Postgres 8.4
  • PHP 5.3.10
  • Mantis 1.2.12
grangeway

grangeway

2014-02-17 13:26

reporter   ~0039440

Marking as Suspended

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-03-27 19:12

reporter   ~0039766

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-05-16 15:00

reporter   ~0040324

MantisBT currently supports Mysql and has support for other database engines.

The support for other databases is known to be problematic.

Having implemented the current database layer into Mantis 10 years ago, I'm currently working on replacing the current layer.

If you are interested in using Mantis with non-mysql databases - for example, Oracle, PGSQL or MSSQL, and would be willing to help out testing the new database layer, please drop me an email at paul@mantisforge.org

In the meantime, I'd advise running Mantis with Mysql Only to avoid issues.

Thanks
Paul

dregad

dregad

2015-03-14 14:02

developer   ~0049222

Despite the fact that I am not actually able to test whether the problem is truly resolved since I don't have access to a MSSQL server setup, I'm marking this issue as fixed in 1.3.x on the grounds that the recent updates in ADOdb (which contain many improvements in the MSSQL driver) are likely to address it.

Should the problem persist (using a nightly build or a version > 1.3.0-beta.1), feel free to reopen this issue or to create a new one.

Issue History

Date Modified Username Field Change
2012-02-16 10:21 portalsoft New Issue
2012-02-20 11:49 dregad Priority urgent => normal
2012-02-20 11:49 dregad Status new => acknowledged
2012-02-20 11:49 dregad Product Version git trunk => 1.2.9
2012-06-05 09:55 atrol Relationship added has duplicate 0014352
2012-12-11 07:18 herick.marques Note Added: 0034527
2014-02-17 13:26 grangeway Note Added: 0039440
2014-03-27 19:12 grangeway Note Added: 0039766
2014-03-27 19:12 grangeway Status acknowledged => resolved
2014-03-27 19:12 grangeway Resolution open => suspended
2014-03-27 19:12 grangeway Assigned To => grangeway
2014-03-28 04:18 atrol Status resolved => assigned
2014-04-12 19:33 grangeway Target Version => 1.3.0-beta.1
2014-05-16 15:00 grangeway Note Added: 0040324
2014-05-23 15:08 grangeway Project mantisbt => @24@
2014-11-07 14:31 atrol Assigned To grangeway =>
2014-11-07 14:31 atrol Status assigned => new
2014-11-07 14:31 atrol Project @24@ => mantisbt
2014-12-08 02:10 atrol Target Version 1.3.0-beta.1 => 1.3.0-beta.2
2015-03-14 14:02 dregad Note Added: 0049222
2015-03-14 14:02 dregad Status new => resolved
2015-03-14 14:02 dregad Fixed in Version => 1.3.0-beta.2
2015-03-14 14:02 dregad Resolution suspended => fixed
2015-03-14 14:02 dregad Assigned To => dregad
2015-03-15 19:58 dregad Status resolved => closed