View Issue Details

IDProjectCategoryView StatusLast Update
0013250mantisbtdb mssqlpublic2015-03-15 19:58
ReporteraliboodaAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindows Server 2003OS Version
Product Version1.2.5 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0013250: Can't submit new issue, it will appear "APPLICATION ERROR #1100" "Bug 0 not found"
Description

PHP: 5.2.17
Mantis: 1.2.5
Database: MS SQL Server 2008

My config_inc.php setting as below:

--- For MS SQL Setting ---

$g_hostname = 'Driver={SQL Server};SERVER=TPEIBTNAS2;DATABASE=mantisBT;UID=mantisdbuser;PWD=root;';
$g_db_username = 'mantisdbuser';
$g_db_password = 'root';
$g_database_name = 'mantisBT';
$g_db_type = 'odbc_mssql';

I have search many issue number about this on site, but it seems no a similar issue like mine. Could anyone give me some advise to solve the problem? Thanks.

Steps To Reproduce
  1. Install Apache 2.2.15
  2. Install PHP 5.2.17, and compile to Apache
  3. Install MS SQL Server 2008, and create a database named: mantisBT for Mantis.
  4. Install Mantis 1.2.5 version, and pass all setting abbout install.php.
  5. Login system by administrator, and go to click "report issue"
  6. Fill in necessary information about issue, then click submit. It display "APPLICATION ERROR #1100 Bug 0 not found.
TagsNo tags attached.

Activities

spralleur

spralleur

2012-01-06 10:13

reporter   ~0030830

I have the same problem.

grangeway

grangeway

2014-02-17 13:26

reporter   ~0039447

Marking as Suspended

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-03-27 19:12

reporter   ~0039758

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-05-16 15:00

reporter   ~0040329

MantisBT currently supports Mysql and has support for other database engines.

The support for other databases is known to be problematic.

Having implemented the current database layer into Mantis 10 years ago, I'm currently working on replacing the current layer.

If you are interested in using Mantis with non-mysql databases - for example, Oracle, PGSQL or MSSQL, and would be willing to help out testing the new database layer, please drop me an email at paul@mantisforge.org

In the meantime, I'd advise running Mantis with Mysql Only to avoid issues.

Thanks
Paul

dregad

dregad

2015-03-14 14:02

developer   ~0049223

Despite the fact that I am not actually able to test whether the problem is truly resolved since I don't have access to a MSSQL server setup, I'm marking this issue as fixed in 1.3.x on the grounds that the recent updates in ADOdb (which contain many improvements in the MSSQL driver) are likely to address it.

Should the problem persist (using a nightly build or a version > 1.3.0-beta.1), feel free to reopen this issue or to create a new one.

Issue History

Date Modified Username Field Change
2011-08-19 06:31 alibooda New Issue
2012-01-06 10:13 spralleur Note Added: 0030830
2014-02-17 13:26 grangeway Note Added: 0039447
2014-03-27 19:12 grangeway Note Added: 0039758
2014-03-27 19:12 grangeway Status new => resolved
2014-03-27 19:12 grangeway Resolution open => suspended
2014-03-27 19:12 grangeway Assigned To => grangeway
2014-03-28 04:18 atrol Status resolved => assigned
2014-04-12 19:33 grangeway Target Version => 1.3.0-beta.1
2014-05-16 15:00 grangeway Note Added: 0040329
2014-05-23 15:08 grangeway Project mantisbt => @24@
2014-11-07 14:30 atrol Assigned To grangeway =>
2014-11-07 14:30 atrol Status assigned => new
2014-11-07 14:30 atrol Project @24@ => mantisbt
2014-12-08 02:10 atrol Target Version 1.3.0-beta.1 => 1.3.0-beta.2
2015-03-14 14:02 dregad Note Added: 0049223
2015-03-14 14:02 dregad Status new => resolved
2015-03-14 14:02 dregad Fixed in Version => 1.3.0-beta.2
2015-03-14 14:02 dregad Resolution suspended => fixed
2015-03-14 14:02 dregad Assigned To => dregad
2015-03-15 19:58 dregad Status resolved => closed