View Issue Details

IDProjectCategoryView StatusLast Update
0013078mantisbtlocalizationpublic2012-10-18 18:01
ReporterkiangAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.2.5 
Target VersionFixed in Version 
Summary0013078: Updated translation for traditional chinese( mantisbt_root/lang/strings_chinese_traditional.txt )
Description

Provided by Barlos@TWPUG in the following post:
http://twpug.net/modules/newbb/viewtopic.php?topic_id=6035

TagsNo tags attached.

Activities

kiang

kiang

2011-06-13 04:15

reporter  

mantisbt125_tw_zht.zip (20,947 bytes)
atrol

atrol

2011-06-13 05:53

developer   ~0028984

kiang, if you are interested you can contribute to MantisBT by following these instructions to change translations
http://www.mantisbt.org/wiki/doku.php/mantisbt:translationshowto

kiang

kiang

2011-06-13 06:20

reporter   ~0028989

Hi atrol,

I just tried to forward translations found in our community to upstream. The translation provided by Barlos looked like more completed than the one in git repository. So I created this issue.

Thanks for your information. :)

atrol

atrol

2011-06-13 07:01

developer   ~0028990

http://translatewiki.net/wiki/Translating:MantisBT/stats/trunk says that Chinese traditional is 99.83% complete at the moment
Maybe you can tell Barlos to update just the changed/added messages at translatewiki.net

kiang

kiang

2011-06-13 07:21

reporter   ~0028991

The message was forwarded. Hope he would create an account there. :)

Barlos

Barlos

2011-06-14 22:23

reporter   ~0028996

Last edited: 2011-06-15 01:53

View 3 revisions

Hello all,

I am Barlos.

I did tried to go translatwiki.net, however I was having hard time with User Interface. So, I just edit language file and posted.

The 2 major differences between the Chinese file came with the MantisBT installation package and the one I modified are addressed as the following.
1: Mine added all the missing strings form the English file.
2: Mine put the strings' order matches to English file. So, easier for people to compare the two files.

I didn't modified the Chinese strings made by the previous translators. However, I did noticed that some translation may lead user to misunderstood. I will look deep into the Chinese translation later and give some thoughts.

Since the language file is just a php text file, which can be edited by any text eidtor, so, people are welcome to modified to suit their prefer.

The following is the Chinese translation form the above message.
(下為上面的中文翻譯)

我有嘗試使用 translatwiki.net 來協助 MantisBT 中文化, 但是使用者介面我弄不懂, 就乾脆自己修改中文化檔案.

MantisBT 安裝檔內附的中文語系檔與我個人修改的, 兩個主要差異如下:
1: 我的是對照英文語系檔, 把沒有放進去的給補進去.
2: 把字串依照英文檔的順序, 重新排序, 所以, 用這個檔案, 如果你要修改, 可以參照英文的檔案內的字串位置.

我沒有對原先的已中文化的字串做修改, 但我發發現有些中文字串翻譯可能會誤導使用者; 我會找時間, 整個對過, 並在此報告. 總共有一千五百個字串...

因為語言檔是 php 的文字檔, 任何人都可以下載並修改成自己的偏好用詞.

atrol

atrol

2011-06-15 01:44

developer   ~0028997

Reminder sent to: siebrand

siebrand, could you please have a look at this?

atrol

atrol

2012-10-06 03:34

developer   ~0033051

Settings status to resolved as translatewiki shows a quite complete translation for chinese traditional.
There are just 6 messages which are not translated at the moment.
http://translatewiki.net/w/i.php?title=Special:Translate&group=out-mantis-0-all&language=zh-hant

Issue History

Date Modified Username Field Change
2011-06-13 04:15 kiang New Issue
2011-06-13 04:15 kiang File Added: mantisbt125_tw_zht.zip
2011-06-13 05:53 atrol Note Added: 0028984
2011-06-13 05:53 atrol Status new => feedback
2011-06-13 06:20 kiang Note Added: 0028989
2011-06-13 06:20 kiang Status feedback => new
2011-06-13 07:01 atrol Note Added: 0028990
2011-06-13 07:01 atrol Status new => feedback
2011-06-13 07:21 kiang Note Added: 0028991
2011-06-13 07:21 kiang Status feedback => new
2011-06-14 22:23 Barlos Note Added: 0028996
2011-06-15 01:44 atrol Note Added: 0028997
2011-06-15 01:52 Barlos Note Edited: 0028996 View Revisions
2011-06-15 01:53 Barlos Note Edited: 0028996 View Revisions
2012-09-21 18:47 atrol Status new => feedback
2012-10-06 03:34 atrol Note Added: 0033051
2012-10-06 03:34 atrol Status feedback => resolved
2012-10-06 03:34 atrol Resolution open => fixed
2012-10-06 03:34 atrol Assigned To => atrol
2012-10-18 18:01 atrol Status resolved => closed