View Issue Details

IDProjectCategoryView StatusLast Update
0012825mantisbtreportspublic2016-07-19 04:19
ReportercobexerAssigned Tovboctor 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Versiongit trunk 
Target Version2.0.0-beta.1Fixed in Version2.0.0-beta.1 
Summary0012825: Modern graphs using javascript graphing library
Description

Doing the graphs on the client side allows for user interactivity like showing / hiding series, hovering over data-points to view their values,...
I don't know how mantis Graphs look like since I never got graphs working with mantis, but i know that flot graphs look nice and work well.

As a side effect you could drop the dependency on the PHP drawing code.
Since you are planning bigger changes to mantis anyway i thought i share that idea now ;)

Additional Information

http://code.google.com/p/flot/
The plugin works with Internet Explorer 6/7/8, Firefox 2.x+, Safari 3.0+, Opera 9.5+ and Konqueror 4.x+ with the HTML canvas tag (the excanvas Javascript emulation helper is used for IE).

TagsNo tags attached.

Relationships

related to 0017493 closedvboctor Graphs are not working out of the box 
has duplicate 0010656 closedvboctor Use openflashcharts for rendering 
has duplicate 0006874 closedvboctor Support for PHP/SWF Charts 
related to 0021177 closedvboctor Jpgraph doesn't work 
related to 0019349 closedvboctor Graphs are not shown 
related to 0006663 closedvboctor I'm seeing three JPGraph-related problems 
related to 0012967 closedvboctor Category jpGraph not displayed 
related to 0010403 closedvboctor The legend on JPGraph graphs overlays the graph 

Activities

vboctor

vboctor

2015-01-22 01:26

manager   ~0042232

I'm working on using chart.js for all graphs.
http://www.chartjs.org/

dregad

dregad

2015-01-22 03:13

developer   ~0042238

Is this for 1.3 or 2.0 ? Just asking, since I have work in progress for fixing the MantisGraph plugin in 1.3, to know if it's worth the effor to finish it.

vboctor

vboctor

2015-01-24 21:15

manager   ~0048673

I'm hoping for 1.3. What kind of fixes were you working on?

dregad

dregad

2015-01-26 02:57

developer   ~0048685

A collection of various fixes, minor improvements and several html/css adjustments for 1.3.

https://github.com/dregad/mantisbt/tree/graph

vboctor

vboctor

2016-07-04 17:07

manager   ~0053507

PR: https://github.com/mantisbt/mantisbt/pull/810

vboctor

vboctor

2016-07-04 17:08

manager   ~0053508

See the video below for the new experience:
http://www.screencast.com/t/KjEzJ1AjtQF

Here are some samples of the old experience:
http://www.screencast.com/t/KJ7rX9fryv
http://www.screencast.com/t/5CN0pWjHV
http://www.screencast.com/t/I5llI4QOQ9l

Issue History

Date Modified Username Field Change
2011-02-28 14:21 cobexer New Issue
2014-11-25 11:04 vboctor Category graphs => reports
2015-01-22 01:26 vboctor Assigned To => vboctor
2015-01-22 01:26 vboctor Status new => assigned
2015-01-22 01:26 vboctor Summary Implement Graphs using flot to allow for client side interactivity => Modern graphs using javascript graphing library
2015-01-22 01:26 vboctor Note Added: 0042232
2015-01-22 03:13 dregad Note Added: 0042238
2015-01-24 21:15 vboctor Note Added: 0048673
2015-01-26 02:57 dregad Note Added: 0048685
2015-02-03 02:22 vboctor Relationship added related to 0017493
2015-04-28 03:28 vboctor Relationship added has duplicate 0010656
2016-07-04 17:07 vboctor Note Added: 0053507
2016-07-04 17:08 vboctor Note Added: 0053508
2016-07-09 16:38 vboctor Status assigned => resolved
2016-07-09 16:38 vboctor Resolution open => fixed
2016-07-09 16:38 vboctor Fixed in Version => 2.0.0-beta.1
2016-07-09 16:38 vboctor Target Version => 2.0.0-beta.1
2016-07-09 16:43 vboctor Relationship added related to 0021177
2016-07-09 16:44 vboctor Relationship added related to 0019349
2016-07-09 16:45 vboctor Relationship added related to 0006663
2016-07-09 16:46 vboctor Relationship added related to 0012967
2016-07-09 16:46 vboctor Relationship added related to 0010403
2016-07-09 16:47 vboctor Relationship added has duplicate 0006874
2016-07-19 04:19 vboctor Status resolved => closed