View Issue Details

IDProjectCategoryView StatusLast Update
0012409mantisbtroadmappublic2016-08-28 01:12
ReporterneicoAssigned Tocproensa 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.3 
Target Version1.3.1Fixed in Version1.3.1 
Summary0012409: "Scheduled For Release" even if no date is set
Description

The Roadmap shows "Scheduled For Release <date>" even if there is no date set on the version which results into showing "Scheduled For Release 01.01.1970" as date...

Additional Information

there are 2 ways to possible solve this.

  1. set $g_show_roadmap_dates OFF so that it never shows the dates (which may not be wanted on all cases)
  2. edit roadmap_page.php on line 40-46 to check if $p_version_row['date_order'] == 1 (which is what it returns if no date is set)

this would allow to set some versions with a scheduled release date and some with an undetermined date (which won't show up at all)

TagsNo tags attached.

Relationships

has duplicate 0021406 closedatrol Roadmap Date if not set shows incorrect Date 

Activities

atrol

atrol

2010-09-28 06:47

developer   ~0026888

I am wondering: When adding a version the date is alway set

neico

neico

2010-09-28 09:35

reporter   ~0026890

but you can always remove it manually and the script does accept it (if that's going to change then maybe changing it so that the situation mentioned can be archived)

atrol

atrol

2010-09-28 10:54

developer   ~0026891

You are right, I was not aware that the date can be removed by using the MantisBT UI.
I thought that you have to manipulate the database for it.

atrol

atrol

2016-07-27 15:29

developer   ~0053716

Part of a private discussion with @cproensa I had today.

...
Not sure if the provided solution is the right one (check if $p_version_row['date_order'] == 1)
as there is also 0021406 where the date is 0 but not 1.
This might be caused by different databases or by upgrades from older versions (we did not store as int values in earlier versions)
or by time zone issues.
I have no time to have a deeper look for it.
The quick and a bit dirty way would be to check for <= 1
...

cproensa

cproensa

2016-07-27 16:30

developer   ~0053717

I checked in my case it's NOT a schema related problem (due to upgrading from older versions)
When date is set empty, the date field is saved as default value ('1'), which then is showed as 1970-01-01 ...

Ideally, the date field should be able to be set empty, meaning a version has no release date. This could be achieved by several ways
1) Allowing NULL for this field. NULL meaning no date exists.
2) Using a special value of 0 (or current default as 1) to mean than no date exists.

Usually, devs are reluctant to mantain nullable db fields due to DB portability, so option (2) may be the best to be implemented.

cproensa

cproensa

2016-07-28 19:31

developer   ~0053722

https://github.com/mantisbt/mantisbt/pull/827
https://github.com/mantisbt/mantisbt/pull/828

Related Changesets

MantisBT: master 2a8f4c36

2016-07-28 19:15:52

cproensa


Committer: vboctor Details Diff
Don't show version release date if not set

In roadmap, dont show release date if it's not set.
When the date is not explicitly set, its stored as 1 in database.
Logically it means "date null", but it was being shown as an actual
date: 1970-01-01

When not showing date, also becasue of option $g_show_roadmap_dates set
to OFF, do not show the calendar icon.

Fixes: 0012409
mod - roadmap_page.php Diff File

MantisBT: master-1.3.x 79976d43

2016-07-28 19:27:03

cproensa


Committer: vboctor Details Diff
Don't show version release date if not set

In roadmap, dont show release date if it's not set.
When the date is not explicitly set, its stored as 1 in database.
Logically it means "date null", but it was being shown as an actual
date: 1970-01-01

Fixes: 0012409
mod - roadmap_page.php Diff File

Issue History

Date Modified Username Field Change
2010-09-28 06:26 neico New Issue
2010-09-28 06:47 atrol Note Added: 0026888
2010-09-28 06:47 atrol Status new => feedback
2010-09-28 09:35 neico Note Added: 0026890
2010-09-28 09:35 neico Status feedback => new
2010-09-28 10:54 atrol Note Added: 0026891
2010-09-28 10:55 atrol Status new => confirmed
2016-07-21 16:26 atrol Relationship added has duplicate 0021406
2016-07-27 15:29 atrol Note Added: 0053716
2016-07-27 16:30 cproensa Note Added: 0053717
2016-07-28 19:15 cproensa Assigned To => cproensa
2016-07-28 19:15 cproensa Status confirmed => assigned
2016-07-28 19:31 cproensa Note Added: 0053722
2016-07-29 05:30 vboctor Changeset attached => MantisBT master-1.3.x 79976d43
2016-07-29 05:30 vboctor Assigned To cproensa => vboctor
2016-07-29 05:30 vboctor Status assigned => resolved
2016-07-29 05:30 vboctor Resolution open => fixed
2016-07-29 05:30 vboctor Fixed in Version => 1.3.1
2016-07-29 05:32 vboctor Changeset attached => MantisBT master 2a8f4c36
2016-07-29 05:34 vboctoradmin Assigned To vboctor => cproensa
2016-07-29 05:34 vboctoradmin Target Version => 1.3.1
2016-08-28 01:12 vboctor Status resolved => closed