View Issue Details

IDProjectCategoryView StatusLast Update
0012205mantisbtbugtrackerpublic2014-12-08 00:34
ReporterSergiodfAssigned Todhx 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.1 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0012205: Do not leave feedback status when the handler adds a note
Description

In Mantis default configuration, when an issue in feedback status gets a new note from the reporter, automatically change its status to new or assigned.

I work with lazy people who never fill in an issue, so I have to report by myself. In this case, it is not good the issue leave feedback status when I add a note, so I make a little fix to prevent it to happen when the note is added by the handler of the issue.

Steps To Reproduce
  1. Report an issue and assign to yourself.
  2. Change it to feedback status.
  3. Add a note.
    What happen: issue automatically leaves feedback status.
    What would I want to happen: issue stays in feedback status.
Tagspatch

Relationships

related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 
related to 0011758 closeddhx Adding a bug note should not change the status of the issue 
child of 0012097 closedatrol Tracking issue for the refactoring of bug_update.php 

Activities

Sergiodf

Sergiodf

2010-07-28 12:03

reporter  

12205.diff (915 bytes)
--- /mantis/mantisbt-1.2.1-official/core/bugnote_api.php	Fri Apr 23 14:28:34 2010
+++ /mantis/mantisbt-1.2.1-patches/core/bugnote_api.php	Wed Jul 28 12:44:29 2010
@@ -189,9 +189,11 @@
 	history_log_event_special( $p_bug_id, BUGNOTE_ADDED, bugnote_format_id( $t_bugnote_id ) );
 
 	# if it was FEEDBACK its NEW_ now
-	if ( config_get( 'reassign_on_feedback' ) &&
-		bug_get_field( $p_bug_id, 'status' ) == config_get( 'bug_feedback_status' ) &&
-		bug_get_field( $p_bug_id, 'reporter_id' ) == $c_user_id ) {
+	if	(	config_get( 'reassign_on_feedback' )
+		&&	bug_get_field( $p_bug_id, 'status' ) == config_get( 'bug_feedback_status' )
+		&&	bug_get_field( $p_bug_id, 'reporter_id' ) == $c_user_id
+		&&	bug_get_field( $p_bug_id, 'handler_id') != $c_user_id
+		) {
 
 		if ( bug_get_field( $p_bug_id, 'handler_id') == 0 ) {
 			bug_set_field( $p_bug_id, 'status', config_get( 'bug_submit_status' ) );
12205.diff (915 bytes)
dhx

dhx

2010-08-10 09:24

reporter   ~0026264

Thanks for your patch Sergio.

Unfortunately I think your patch may be incorrect.

The reassign on feedback feature is meant to allow developers a chance to request feedback from the reporter of the issue. Once that reporter provides feedback in a note, the status is meant to change to either $g_bug_submit_status if no handler is defined for the bug or $g_bug_assigned_status if a handler is defined.

Your patch essentially disables the feature entirely. I think you may be better to just set $g_reassign_on_feedback = OFF in your configuration to turn the feature off on your bug tracker.

dhx

dhx

2010-08-14 01:16

reporter   ~0026310

Sorry, I understand the problem now.

This should be fixed now in the 1.3.x branch.

If the handler of the issue is also the reporter of the issue and this person is replying when the status is "feedback", the reassign on feedback feature should not apply.

Thanks Sergio!

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036470

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Related Changesets

MantisBT: master 95ac1e0c

2010-08-14 05:12:51

dhx

Details Diff
Fix 0012205: Disable reassign on feedback when the handler replies

If the handler of an issue replies to a bug in the "feedback" status
then the reassign on feedback feature should not apply.
mod - bugnote_add.php Diff File
mod - bug_update.php Diff File

Issue History

Date Modified Username Field Change
2010-07-28 12:01 Sergiodf New Issue
2010-07-28 12:01 Sergiodf Tag Attached: patch
2010-07-28 12:03 Sergiodf File Added: 12205.diff
2010-08-10 09:24 dhx Note Added: 0026264
2010-08-10 09:24 dhx Assigned To => dhx
2010-08-10 09:24 dhx Status new => feedback
2010-08-14 01:03 dhx Relationship added related to 0011758
2010-08-14 01:04 dhx Relationship added child of 0012097
2010-08-14 01:14 dhx Changeset attached => MantisBT master 95ac1e0c
2010-08-14 01:14 dhx Resolution open => fixed
2010-08-14 01:14 dhx Fixed in Version => 1.3.0-beta.1
2010-08-14 01:14 dhx Resolution fixed => open
2010-08-14 01:14 dhx Fixed in Version 1.3.0-beta.1 =>
2010-08-14 01:14 dhx Target Version => 1.3.0-beta.1
2010-08-14 01:16 dhx Note Added: 0026310
2010-08-14 01:16 dhx Status feedback => resolved
2010-08-14 01:16 dhx Resolution open => fixed
2010-08-14 01:16 dhx Fixed in Version => 1.3.0-beta.1
2013-04-05 17:57 grangeway Status resolved => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036470
2013-04-05 18:07 grangeway Relationship added related to 0015721
2013-04-06 03:44 dregad Status acknowledged => resolved
2013-04-06 07:20 grangeway Status resolved => acknowledged
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check
2014-12-08 00:34 vboctor Status resolved => closed