View Issue Details

IDProjectCategoryView StatusLast Update
0012096mantisbtfeaturepublic2014-12-08 00:34
ReporterdhxAssigned Todhx 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.2.2 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0012096: On marking an issue as a duplicate add the reporter and handler to the monitor list of the destination bug
Description

When an issue X is resolved as a duplicate of an existing issue Y, the monitor list from X is copied to and merged with Y. However the reporter and handler of the source issue are not copied unless they're on the monitor list.

It'd be helpful if this behavior was changed so that the reporter and handler were added to the monitor list of the destination bug so they don't mistakenly become 'out-of-the-loop' on updates to the issue.

TagsNo tags attached.

Relationships

child of 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 

Activities

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036505

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Related Changesets

MantisBT: master 4c791523

2010-06-19 04:38:26

dhx

Details Diff
Issue 0012096: Add reporter and handler to monitor list on duplicate

When an issue X is resolved as a duplicate of an existing issue Y, the
monitor list from X is copied to and merged with Y. However the reporter
and handler of the source issue are not copied unless they're on the
monitor list.

This change ensures that the reporter and handler of the source issue
are added to the monitor list on the destination issue. These users are
thus less likely to become out-of-the-loop on an issue that is relevant
to them.
mod - core/bug_api.php Diff File

Issue History

Date Modified Username Field Change
2010-06-19 00:31 dhx New Issue
2010-06-19 00:31 dhx Status new => assigned
2010-06-19 00:31 dhx Assigned To => dhx
2010-06-22 21:40 dhx Changeset attached => MantisBT master 4c791523
2010-06-22 22:52 dhx Target Version 1.2.2 => 1.3.0-beta.1
2010-06-22 22:52 dhx Status assigned => resolved
2010-06-22 22:52 dhx Fixed in Version => 1.3.0-beta.1
2010-06-22 22:52 dhx Resolution open => fixed
2013-04-05 17:57 grangeway Status resolved => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036505
2013-04-05 18:02 grangeway Relationship added child of 0015721
2013-04-06 03:44 dregad Status acknowledged => resolved
2013-04-06 07:20 grangeway Status resolved => acknowledged
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check
2014-12-08 00:34 vboctor Status resolved => closed