View Issue Details

IDProjectCategoryView StatusLast Update
0011576mantisbtadministrationpublic2014-12-08 00:34
ReporterdhxAssigned Todhx 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0011576: New and improved check.php for checking MantisBT installation settings/environment
Description

The existing check.php in the admin/ directory is outdated and of poor quality to users. This check script needs a complete rewrite from scratch to make it more user friendly, provide a wider range of checks and have improved grammar/descriptions to make the test results easier for users to digest.

The new check system should be modular in nature so that it is easy to find and add checks in the future as the MantisBT project grows.

TagsNo tags attached.

Relationships

related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 
related to 0013545 closeddregad Admin check for PHP has incorrect logic to verify PHP errors logging 
related to 0012885 closeddregad Reimplement obsolete configuration checks based on obsolete.php as part of new admin/check/ interface 

Activities

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036396

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Related Changesets

MantisBT: master ba97560b

2010-02-16 10:40:56

dhx

Details Diff
Issue 0011576: New and improved admin/check.php functionality

The existing check.php in the admin/ directory is outdated and of poor
quality to users. This check script needed a complete rewrite from
scratch to make it more user friendly, provide a wider range of checks
and have improved grammar/descriptions to make the test results easier
for users to digest.

The new check system is modular in nature so that it is easy to find and
add checks in the future as the MantisBT project grows. Thus it is
possible to include some of these "modules" in other administration
scripts (such as the installer).

Most of the old checks are carried over (with some deliberately left
out) and many new checks have been added.

This new system also includes a MantisBT installation integrity checker
that determines the hash of each file in a MantisBT installation to see
if it originates from an official release. This functionality makes it
easier for users to recognise failed upgrades (where new files haven't
overwritten old ones). More importantly, it is hoped that this
functionality can reduce the number of invalid bug reports at
mantisbt.org/bugs due to people making errors with custom "hard hacks"
to their MantisBT installations.
add - admin/check/check_config_inc.php Diff File
add - admin/check/check_email_inc.php Diff File
add - admin/check/check_attachments_inc.php Diff File
add - admin/check/check_php_inc.php Diff File
add - admin/check/check_paths_inc.php Diff File
add - admin/check/check_anonymous_inc.php Diff File
add - admin/check/check_display_inc.php Diff File
mod - admin/admin.css Diff File
add - admin/check/check_database_inc.php Diff File
mod - config_defaults_inc.php Diff File
rm - admin/check.php Diff File
mod - core.php Diff File
add - admin/check/check_L10n_inc.php Diff File
add - admin/check/index.php Diff File
add - admin/check/check_integrity_inc.php Diff File
add - admin/check/check_api.php Diff File
add - admin/check/check_crypto_inc.php Diff File
mod - core/database_api.php Diff File
add - admin/check/check_i18n_inc.php Diff File

MantisBT: master d1cd06cd

2011-10-23 16:30:13

dregad

Details Diff
Reimplement obsolete config checks in admin/check interface

The rewritten check.php scripts (as a collection of checks in the
admin/check/ directory), implemented per issue 0011576 in commit
ba97560b02d620569ad062d894284722f0acd890, neglected to port across
obsolete configuration checking from 1.2.x.

Fixes 0012885
mod - admin/check/check_config_inc.php Diff File
mod - core/config_api.php Diff File

MantisBT: master 88ca322b

2011-11-19 13:26:43

dregad

Details Diff
Fix PHP admin check for error logging/reporting

The check for "PHP errors are being logged or reported" in the new
admin check interface has incorrect logic, causing it to always report
a warning condition.

The warning should only be printed if both display_errors and
log_errors are Off.

Fixes 0013545, 0011576
mod - admin/check/check_php_inc.php Diff File

Issue History

Date Modified Username Field Change
2010-03-01 05:43 dhx New Issue
2010-03-01 05:43 dhx Status new => assigned
2010-03-01 05:43 dhx Assigned To => dhx
2010-03-01 05:56 dhx Status assigned => resolved
2010-03-01 05:56 dhx Fixed in Version => 1.3.0-beta.1
2010-03-01 05:56 dhx Resolution open => fixed
2010-03-01 06:00 dhx Changeset attached master ba97560b =>
2010-06-09 03:44 dhx Status resolved => closed
2011-11-19 16:14 dregad Issue cloned: 0013545
2011-11-19 16:14 dregad Relationship added related to 0013545
2011-11-19 17:01 dregad Relationship added related to 0012885
2011-12-05 12:32 dregad Changeset attached => MantisBT master d1cd06cd
2011-12-05 12:32 dregad Changeset attached => MantisBT master 88ca322b
2013-04-05 17:57 grangeway Status closed => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036396
2013-04-05 18:14 grangeway Relationship added related to 0015721
2013-04-06 03:44 dregad Status acknowledged => resolved
2013-04-06 07:20 grangeway Status resolved => acknowledged
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check
2014-12-08 00:34 vboctor Status resolved => closed