View Issue Details

IDProjectCategoryView StatusLast Update
0011571mantisbtadministrationpublic2010-04-23 14:30
ReportersimtelAssigned Todhx 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.0 
Target Version1.2.1Fixed in Version1.2.1 
Summary0011571: Cannot edit some versions
Description

After upgrading to 1.2.0 I've found that I cannot edit some versions.

I have a project with versions:

1.20
...
1.10
1.9
...
1.2
1.1

When I click on "Edit" next to 1.2, mantis shows me the 1.20 properties. When I click 1.1 it shows me 1.10!

Is there an hidden settings to turn this behaviour off or is it just a plain bug? :)

I'm using PostgreSQL, if it matters.

TagsNo tags attached.

Relationships

Activities

atrol

atrol

2010-02-28 09:37

developer   ~0024568

reproduced with mySQL, not related to database

dhx

dhx

2010-02-28 20:28

reporter   ~0024572

Thanks for reporting this bug. I've fixed it ready for the next minor release 1.2.1 :)

Related Changesets

MantisBT: master-1.2.x 3cca9275

2010-03-01 01:22:55

dhx

Details Diff
Fix 0011571: Versions 1.1 and 1.10 are treated as duplicates

A problem was discovered on manage_proj_edit_page.php where if versions
1.1 and 1.10 were both shown, clicking 'edit' for 1.1 would bring up the
edit version page for the 1.10 version instead.

This is due to an incorrect version name comparison in version_get_id
whereby the following check between strings was occurring:

if( "1.1" == "1.10" ) { ... }

PHP evaluates this expression to true because 1.1 and 1.10 are treated
as floats. We however need to preserve the string type during this
comparison, thus we need to use the === comparison operator instead.
mod - core/version_api.php Diff File

MantisBT: master 0e5ad6ca

2010-03-01 01:22:55

dhx

Details Diff
Fix 0011571: Versions 1.1 and 1.10 are treated as duplicates

A problem was discovered on manage_proj_edit_page.php where if versions
1.1 and 1.10 were both shown, clicking 'edit' for 1.1 would bring up the
edit version page for the 1.10 version instead.

This is due to an incorrect version name comparison in version_get_id
whereby the following check between strings was occurring:

if( "1.1" == "1.10" ) { ... }

PHP evaluates this expression to true because 1.1 and 1.10 are treated
as floats. We however need to preserve the string type during this
comparison, thus we need to use the === comparison operator instead.
mod - core/version_api.php Diff File

Issue History

Date Modified Username Field Change
2010-02-28 09:24 simtel New Issue
2010-02-28 09:37 atrol Note Added: 0024568
2010-02-28 09:37 atrol Status new => confirmed
2010-02-28 20:27 dhx Status confirmed => assigned
2010-02-28 20:27 dhx Assigned To => dhx
2010-02-28 20:27 dhx Target Version => 1.2.2
2010-02-28 20:28 dhx Note Added: 0024572
2010-02-28 20:28 dhx Status assigned => resolved
2010-02-28 20:28 dhx Fixed in Version => 1.2.2
2010-02-28 20:28 dhx Resolution open => fixed
2010-02-28 20:30 dhx Changeset attached master-1.2.x 3cca9275 =>
2010-02-28 20:30 dhx Changeset attached master 0e5ad6ca =>
2010-04-23 14:30 jreese Status resolved => closed