View Issue Details

IDProjectCategoryView StatusLast Update
0011549mantisbtinstallationpublic2014-12-08 00:34
ReporterPapstAssigned Todregad 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformApache 2.2 / PHP 5.2.xOSGentooOS Version
Product Version1.2.0 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0011549: PHP include_path change restriction
Description

Hi,

I've tried to install MantisBT 1.2 on my Webserver.
The Installation Screen showed me an empty page.

I figured out that the php setting 'include_path' is restricted from the hoster so the script can't change this!
The install.php didn't show any error because it includes the core.php with @ (error_reporting = 0).

TagsNo tags attached.

Activities

llattan

llattan

2010-02-24 17:19

reporter   ~0024495

I had the same error.

If you have copied config_inc.php.sample to config_inc.php (and adjusted parameters) you could have got an empty page.

The file config_inc.php.sample hasn't got closing php statement.

I suggest to add
?>
at the end of the file.
Try this.

Leandro.

giallu

giallu

2010-02-24 18:59

reporter   ~0024498

Closing php tags are not needed, and sometimes harmful, so we removed all of them from php files.

dhx

dhx

2010-02-25 01:31

reporter   ~0024508

I've been writing out the need for setting the include path in MantisBT 1.3.x

There are still a few remaining places where include_path is set in MantisBT as per http://git.mantisbt.org/?p=mantisbt.git&a=search&h=HEAD&st=grep&s=include_path but they're on the agenda for removal.

I suggest using a nightly build of MantisBT 1.3.x as this problem should be mostly resolved for now. The only things that probably won't work are the MantisGraph plugin and SOAP functionality. I'll try and fix those soon!

giallu

giallu

2010-02-25 04:28

reporter   ~0024513

I don't think I agree on this change...

dhx

dhx

2010-02-25 08:51

reporter   ~0024522

Mantis has configuration options to let users select the paths in which required files are located. If we already know the path and filenames there is little need for PHP to try finding files itself... we may as well just tell PHP directly which files we want to include. Otherwise PHP has to check every directory in the include path list for the desired file (when it doesn't have to). This also avoids possible problems with filename collisions.

jsm11482

jsm11482

2010-11-12 22:49

reporter   ~0027353

I'm still having this issue with the 1.2.3 release. I agree with dhx that it doesn't make sense to alter the include path when you already know the location of the file. Any idea when this will be fixed? I guess I'll try a nightly build...

jsm11482

jsm11482

2010-11-12 23:01

reporter   ~0027354

FYI I ended up rolling back to my previous install (1.1.7). The 1.3 development version does not appear to be available on SourceForge and I don't want to mess with the nightly build. Thanks.

atrol

atrol

2013-04-27 18:44

developer   ~0036711

Removed assignment. dhx will not contribute to this issue in near future.

dregad

dregad

2014-03-24 09:40

developer   ~0039727

Please review https://github.com/mantisbt/mantisbt/pull/150

Related Changesets

MantisBT: master 3c238977

2014-03-23 21:07:50

dregad

Details Diff
Remove set_include_path() calls

Since we know the full path to the files being included, it is not
necessary to change the include path.

Fixes 0011549
mod - api/soap/mantisconnect.php Diff File
mod - core/plugin_api.php Diff File
mod - plugins/MantisGraph/MantisGraph.php Diff File
mod - plugins/MantisGraph/core/graph_api.php Diff File
mod - plugins/MantisGraph/pages/bug_graph_bycategory.php Diff File
mod - plugins/MantisGraph/pages/bug_graph_bystatus.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_bycategory.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_bycategory_pct.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_bydeveloper.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_bypriority.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_bypriority_mix.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_bypriority_pct.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_byreporter.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_byresolution.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_byresolution_mix.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_byresolution_pct.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_byseverity.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_byseverity_mix.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_byseverity_pct.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_bystatus.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_bystatus_pct.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_cumulative_bydate.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_category.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_priority.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_resolution.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_severity.php Diff File
mod - plugins/MantisGraph/pages/summary_graph_imp_status.php Diff File

Issue History

Date Modified Username Field Change
2010-02-24 16:34 Papst New Issue
2010-02-24 17:19 llattan Note Added: 0024495
2010-02-24 18:59 giallu Note Added: 0024498
2010-02-25 01:28 dhx Assigned To => dhx
2010-02-25 01:28 dhx Status new => assigned
2010-02-25 01:28 dhx Target Version => 1.3.0-beta.1
2010-02-25 01:31 dhx Note Added: 0024508
2010-02-25 04:28 giallu Note Added: 0024513
2010-02-25 08:51 dhx Note Added: 0024522
2010-11-12 22:49 jsm11482 Note Added: 0027353
2010-11-12 23:01 jsm11482 Note Added: 0027354
2013-04-27 18:44 atrol Note Added: 0036711
2013-04-27 18:44 atrol Assigned To dhx =>
2013-04-27 18:44 atrol Status assigned => confirmed
2014-01-21 18:26 atrol Target Version 1.3.0-beta.1 =>
2014-03-24 09:40 dregad Note Added: 0039727
2014-03-24 09:40 dregad Assigned To => dregad
2014-03-24 09:40 dregad Status confirmed => assigned
2014-03-24 09:40 dregad Target Version => 1.3.0-beta.1
2014-04-11 10:21 dregad Changeset attached => MantisBT master 3c238977
2014-04-11 10:21 dregad Status assigned => resolved
2014-04-11 10:21 dregad Resolution open => fixed
2014-04-11 10:21 dregad Fixed in Version => 1.3.0-beta.1
2014-12-08 00:34 vboctor Status resolved => closed