View Issue Details

IDProjectCategoryView StatusLast Update
0011495mantisbtbugtrackerpublic2014-12-08 00:34
ReporterdhxAssigned Todhx 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.0 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0011495: Cannot move core, library and language directories out of wwwroot
Description

The options $g_core_path, $g_class_path, $g_library_path and $g_language_path cannot be used properly because in various parts of Mantis' codebase, include/require calls do not make use of these configuration options (instead it is assumed that the default directory structure is used).

TagsNo tags attached.

Relationships

related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 

Activities

giallu

giallu

2010-02-25 04:41

reporter   ~0024514

Uhm, we were trying to move away from absolute paths to include() and require() functions.

Besides "it is assumed that the default directory structure is used" is not really true; instead, it is assumed that you could use any path for storing your libraries just by pointing the include_path to the library/ directory.

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036513

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Related Changesets

MantisBT: master 8696c44c

2010-02-12 02:02:29

dhx

Details Diff
Fix 0011495: Cannot move core, library and language directories

The options $g_core_path, $g_class_path, $g_library_path and
$g_language_path could not be used properly because in various parts of
Mantis' codebase, include/require calls do not make use of these
configuration options (instead it is assumed that the default directory
structure is used).
mod - core.php Diff File
mod - core/lang_api.php Diff File
mod - core/database_api.php Diff File
mod - config_defaults_inc.php Diff File
mod - core/custom_field_api.php Diff File
mod - core/config_api.php Diff File
mod - docbook/adminguide/en/configuration.sgml Diff File
mod - core/relationship_api.php Diff File
mod - plugins/MantisGraph/core/graph_api.php Diff File

Issue History

Date Modified Username Field Change
2010-02-11 20:55 dhx New Issue
2010-02-11 20:55 dhx Status new => assigned
2010-02-11 20:55 dhx Assigned To => dhx
2010-02-11 21:11 dhx Target Version 1.2.2 => 1.3.0-beta.1
2010-02-11 21:12 dhx Status assigned => resolved
2010-02-11 21:12 dhx Fixed in Version => 1.3.0-beta.1
2010-02-11 21:12 dhx Resolution open => fixed
2010-02-11 21:20 dhx Changeset attached master 8696c44c =>
2010-02-25 04:41 giallu Note Added: 0024514
2010-06-09 03:44 dhx Status resolved => closed
2013-04-05 17:57 grangeway Status closed => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036513
2013-04-05 18:04 grangeway Relationship added related to 0015721
2013-04-06 03:44 dregad Status acknowledged => resolved
2013-04-06 07:20 grangeway Status resolved => acknowledged
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check
2014-12-08 00:34 vboctor Status resolved => closed