2014-11-26 16:17 EST

View Issue Details Jump to Notes ] Wiki ]
IDProjectCategoryView StatusLast Update
0010677mantisbtlocalizationpublic2010-04-23 23:22
Reportersveyret 
Assigned Todhx 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
Product Version1.1.8 
Target VersionFixed in Version 
Summary0010677: Signup message uses language of administrator
DescriptionIf an admin create a new account, the message sent to the new user is in the admin language. This actually should be the default_language or at least the fallback_language.
Steps To ReproduceAs administrator, select french as preferred language.
Create a new account.
The new user recieves the message in french.
Tagspatch
Attached Files
  • patch file icon issue10677-1.1.x.patch (1,097 bytes) 2009-07-03 08:17 - 
    From 7de2f79e8e7afcf66c7489b85574c993ca275385 Mon Sep 17 00:00:00 2001
    From: =?utf-8?q?St=82phane=20Veyret?= <sveyret@axway.com>
    Date: Fri, 3 Jul 2009 14:12:43 +0200
    Subject: [PATCH] Fix 0010677: Signup message uses language of administrator
    
    Using default language (or fallback if default is auto)
    ---
     core/email_api.php |    7 +++----
     1 files changed, 3 insertions(+), 4 deletions(-)
    
    diff --git a/core/email_api.php b/core/email_api.php
    index 69c21fa..7d2daa1 100644
    --- a/core/email_api.php
    +++ b/core/email_api.php
    @@ -375,9 +375,8 @@
     					return;
     		}
     
    -#		@@@ thraxisp - removed to address #6084 - user won't have any settings yet,
    -#       use same language as display for the email
    -#       lang_push( user_pref_get_language( $p_user_id ) );
    +		# Use default language for signup since user doesn't have settings yet
    +		lang_push( config_get( 'default_language' ) );
     
     		# retrieve the username and email
     		$t_username = user_get_field( $p_user_id, 'username' );
    @@ -403,7 +402,7 @@
     			}
     		}
     
    -#		lang_pop(); # see above
    +		lang_pop();
     	}
     
     	# --------------------
    -- 
    1.6.3.2
    
    
    patch file icon issue10677-1.1.x.patch (1,097 bytes) 2009-07-03 08:17 + 
  • patch file icon issue10677-master.patch (1,268 bytes) 2009-07-03 08:17 - 
    From 78df78afe6addb92d99f60062d52abc10911c6ec Mon Sep 17 00:00:00 2001
    From: =?utf-8?q?St=82phane=20Veyret?= <sveyret@axway.com>
    Date: Fri, 3 Jul 2009 14:15:56 +0200
    Subject: [PATCH] Fix 0010677: Signup message uses language of administrator
    
    Using default language (or fallback if default is auto)
    ---
     core/email_api.php |    9 ++++-----
     1 files changed, 4 insertions(+), 5 deletions(-)
    
    diff --git a/core/email_api.php b/core/email_api.php
    index 4d9f623..c061cb6 100644
    --- a/core/email_api.php
    +++ b/core/email_api.php
    @@ -408,10 +408,9 @@ function email_signup( $p_user_id, $p_password, $p_confirm_hash, $p_admin_name =
     		return;
     	}
     
    -	#	@@@ thraxisp - removed to address #6084 - user won't have any settings yet,
    -	#  use same language as display for the email
    -	#  lang_push( user_pref_get_language( $p_user_id ) );
    -	# retrieve the username and email
    +	# Use default language for signup since user doesn't have settings yet
    +	lang_push( config_get( 'default_language' ) );
    +
     	$t_username = user_get_field( $p_user_id, 'username' );
     	$t_email = user_get_email( $p_user_id );
     
    @@ -438,7 +437,7 @@ function email_signup( $p_user_id, $p_password, $p_confirm_hash, $p_admin_name =
     		}
     	}
     
    -	#		lang_pop(); # see above
    +	lang_pop();
     }
     
     /**
    -- 
    1.6.3.2
    
    
    patch file icon issue10677-master.patch (1,268 bytes) 2009-07-03 08:17 + 

- Relationships
duplicate of 0007488closedsiebrand [all lang] Creating user from an administrator account sends e-mail in admin's language instead of system-default language 
+ Relationships

-  Notes
User avatar

~0022361

sveyret (reporter)

Added patches for branches 1.1.x and master to select default language for signup.
User avatar

~0022368

jreese (reporter)

Reminder sent to: dhx

David, I think you fixed this. Can you please confirm?
User avatar

~0022394

dhx (reporter)

I haven't fixed this yet, but I can take care of it :)
User avatar

~0022395

dhx (reporter)

Actually this is a duplicate of bug 0007488 fixed by Siebrand in http://git.mantisbt.org/?p=mantisbt.git;a=commitdiff;h=44719eb9f8d7043cb90c816ed8e345ca02634739 [^]

I'll review the current situation to see if Siebrand's earlier patch is working correctly.
+  Notes

- Issue History
Date Modified Username Field Change
2009-07-03 05:50 sveyret New Issue
2009-07-03 08:17 sveyret File Added: issue10677-1.1.x.patch
2009-07-03 08:17 sveyret File Added: issue10677-master.patch
2009-07-03 08:18 sveyret Note Added: 0022361
2009-07-03 13:48 vboctor Tag Attached: patch
2009-07-03 20:19 jreese Note Added: 0022368
2009-07-04 17:35 vboctor Category email => localization
2009-07-05 07:37 dhx Note Added: 0022394
2009-07-05 07:41 dhx Note Added: 0022395
2009-07-05 07:41 dhx Assigned To => dhx
2009-07-05 07:41 dhx Status new => resolved
2009-07-05 07:41 dhx Resolution open => duplicate
2009-07-05 07:41 dhx Relationship added duplicate of 0007488
2010-04-23 23:22 dhx Status resolved => closed
+ Issue History