View Issue Details

IDProjectCategoryView StatusLast Update
0010218mantisbtdb mssqlpublic2015-03-15 19:58
ReporterboivinmiAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1.6 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0010218: Error message: APPLICATION ERROR 0000401
Description

The message received is:

Database query failed. Error received from database was #0: for the query: SELECT DISTINCT mantis_bug_table.* FROM mantis_bug_table WHERE mantis_bug_table.id in (3, 4, 5, 6, .... 3249, 3250) ORDER BY last_updated DESC, date_submitted DESC.
Please use the "Back" button in your web browser to return...

In "My View", the error occurs for the Resolved box.

Things were fine with version 1.1.5, we upgraded because version 1.1.6 solved issue 0009869 we sometime encountered.

Steps To Reproduce

When selecting "My View " or "View Issues"

Additional Information

We are using :
IIS 5.0 on a Windows server 2000 (SP4)
MSSQL Server 2000 on another Windows server 2000 (SP4)
PHP 5.2.9 (php-cgi.exe)

TagsNo tags attached.

Activities

grangeway

grangeway

2014-02-17 13:26

reporter   ~0039448

Marking as Suspended

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-03-27 19:12

reporter   ~0039760

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-05-16 15:00

reporter   ~0040312

MantisBT currently supports Mysql and has support for other database engines.

The support for other databases is known to be problematic.

Having implemented the current database layer into Mantis 10 years ago, I'm currently working on replacing the current layer.

If you are interested in using Mantis with non-mysql databases - for example, Oracle, PGSQL or MSSQL, and would be willing to help out testing the new database layer, please drop me an email at paul@mantisforge.org

In the meantime, I'd advise running Mantis with Mysql Only to avoid issues.

Thanks
Paul

dregad

dregad

2015-03-14 14:02

developer   ~0049216

Despite the fact that I am not actually able to test whether the problem is truly resolved since I don't have access to a MSSQL server setup, I'm marking this issue as fixed in 1.3.x on the grounds that the recent updates in ADOdb (which contain many improvements in the MSSQL driver) are likely to address it.

Should the problem persist (using a nightly build or a version > 1.3.0-beta.1), feel free to reopen this issue or to create a new one.

Issue History

Date Modified Username Field Change
2009-03-17 13:57 boivinmi New Issue
2009-03-18 16:39 jreese Status new => assigned
2009-03-18 16:39 jreese Assigned To => grangeway
2014-02-17 13:26 grangeway Note Added: 0039448
2014-03-27 19:12 grangeway Note Added: 0039760
2014-03-27 19:12 grangeway Status assigned => resolved
2014-03-27 19:12 grangeway Resolution open => suspended
2014-03-28 04:18 atrol Status resolved => assigned
2014-04-12 19:33 grangeway Target Version => 1.3.0-beta.1
2014-05-16 15:00 grangeway Note Added: 0040312
2014-05-23 15:08 grangeway Project mantisbt => @24@
2014-11-07 14:24 atrol Assigned To grangeway =>
2014-11-07 14:24 atrol Status assigned => new
2014-11-07 14:24 atrol Project @24@ => mantisbt
2014-12-08 02:10 atrol Target Version 1.3.0-beta.1 => 1.3.0-beta.2
2015-03-14 14:02 dregad Note Added: 0049216
2015-03-14 14:02 dregad Status new => resolved
2015-03-14 14:02 dregad Fixed in Version => 1.3.0-beta.2
2015-03-14 14:02 dregad Resolution suspended => fixed
2015-03-14 14:02 dregad Assigned To => dregad
2015-03-15 19:58 dregad Status resolved => closed