MantisBT 1.2.1 Released

Hi all,

MantisBT 1.2.1 is a maintenance update for the stable 1.2.x branch. All
installations that are currently running any 1.1.x or 1.2.0 version are
advised to upgrade to this release.

Included with 1.2.1 are a range of bug fixes, translation updates, and general
improvements over the initial 1.2.0 release.  Highlights include an improved
installation, a fixed upgrade path from 1.1.x, fixes to the URL and path
detection, and updates to the plugin event system.

The release changelog can be found at:
   - http://www.mantisbt.org/bugs/changelog_page.php?version_id=109

It can be downloaded at:
   - http://www.mantisbt.org/download.php

Cheers
This entry was posted in MantisBT and tagged , . Bookmark the permalink.

7 Responses to MantisBT 1.2.1 Released

  1. Myrddin says:

    Exists some guide to uptate from 1.2.0 to 1.2.1? Thanks!

  2. julio says:

    hello,

    I am not able to upgrade from 1.1.8 to 1.2.1. I give a blank page when I go to http://avatools.com/seguimientoincidencias/admin/install.php

    If I try this page http://avatools.com/seguimientoincidencias/admin/index.php I get an error message telling me that it cannot find ‘session_validation’ and ‘class_path’ configuration options:

    ————————————————————-
    APPLICATION WARNING #100: No se encuentra la opción de configuración ‘session_validation’.

    APPLICATION WARNING #100: No se encuentra la opción de configuración ‘class_path’.

    SYSTEM WARNING: require_once(MantisPlugin.class.php) [function.require-once]: failed to open stream: No such file or directory

    Fatal error: require_once() [function.require]: Failed opening required ‘MantisPlugin.class.php’ (include_path=’C:\Inetpub\vhosts\avatools.com\httpdocs\SeguimientoIncidencias\core\;C:\Inetpub\vhosts\avatools.com\httpdocs\SeguimientoIncidencias\library;.;./includes;./pear;./include;../include;include;’) in C:\Inetpub\vhosts\avatools.com\httpdocs\SeguimientoIncidencias\core\plugin_api.php on line 33
    ————————————————————-

    any idea?

    thanks a lot

  3. julio says:

    It is installed now. Simply I copied again the directory and that’s all.

    thanks

  4. Nitin Reddy Katkam says:

    Hi!

    @julio

    I have been able to upgrade from 1.1.8 to 1.2.1 directly. The installation for 1.2.1 updates the database as necessary.

  5. Avg00r says:

    I have wrote some guide to update Mantis in my blog:
    http://avg00r.blogspot.com/2010/05/how-to-update-mantisbt.html
    So, i’ve updated Mantis from 1.2.0 to 1.2.1 in this way.

  6. fxmathieu says:

    Hi,

    After migration from 1.1.8 to 1.2.1, I try to connect to admin/index.php, I get this message:

    Database query failed. Error received from database was #1054: Unknown column ‘p.inherit_global’ in ‘field list’ for the query: SELECT DISTINCT p.id, ph.parent_id, p.name, p.inherit_global, ph.inherit_parent
    FROM mantis_project_table p
    LEFT JOIN mantis_project_hierarchy_table ph
    ON ph.child_id = p.id
    WHERE p.enabled = ?
    ORDER BY p.name.

    Can you help me ?

    Thanks a lot

  7. Lars Outzen says:

    Thank you for this very well tested and complete bug-tracking solution. I really appreciate the new links on the roadmap view – but would also like to have direct links to the edit-release pages for planning purposes, i.e. manage_proj_edit_page.php?project_id=$pNo and manage_proj_ver_edit_page.php?version_id=$relNo.
    The revision-history on the Description-field has already come in handy; we don’t need to pase changes into notes fields anymore.

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>