MantisTouch 1.3.1 released

MantisTouch 1.3.1 released (see blog post).  The new release requires MantisBT v1.2.12 or above.  However, MantisBT v1.2.16 is highly recommended and will enable a bunch of extra features.

This entry was posted in MantisBT, MantisTouch. Bookmark the permalink.